Construct 0.99.72 (unstable) released

New releases and general discussions.

Post » Tue Dec 29, 2009 1:03 am

sweetness, python fix.... will try when I get time again.
B
3
S
2
G
4
Posts: 1,445
Reputation: 4,665

Post » Tue Dec 29, 2009 1:29 am

Great batch of fixes. Thanks again, guys! :)
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Tue Dec 29, 2009 4:55 am

for me its still not working 100% since 99.62

multiple objects passed on to a function, picking seems wrong, was set as pending in the tracker

if i take the same function code and put it directly into the event it works

also had a few collision crashes, but will post a new tracker on that
B
2
G
3
Posts: 72
Reputation: 994

Post » Wed Dec 30, 2009 10:38 am

I posted this to the tracker, but seeing as you sometimes update the program several times with an unstable version, I was hoping you might fix this, which seems a simple problem:

From the tracker:
[quote:f6cqbber]When I want to autoplay a resource WAV with XAudio2 using an expression
Construct first displays the last chosen sample (from the dropdown) as a
string, the string being its name. But trying to run the game this way will
not play the sample, even if the name is correct. The only way for it to
work is by writing the index number in the expression window (the index
being where it is chronologically in the Files folder of the Project bar).

Since it automates to making the last sample picked when you switch to use
expression into a string it seem like this was intended to work, but it
doesn't! Fixing it would help as if one were to edit a sample and then
reload it into Construct its index would change.[/quote:f6cqbber]
B
5
S
2
G
3
Posts: 234
Reputation: 1,818

Post » Wed Dec 30, 2009 9:57 pm

[quote="Ashley":ilheda4r]- [FIX] Physics: custom collision masks with a hotspot not in the centre would not work as expected[/quote:ilheda4r]

Is this supposed to affect non-custom mask physics objects as well? I made a large physics object with the hotspot located in the upper left and the collision was off, but this was using Bounding Box.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Thu Dec 31, 2009 2:04 am

Deadeye, I don't think so - post a bug and assign it to Davo if you think it's still broke, that's his changelog item.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Fri Jan 01, 2010 3:40 am

Ooohhh, sweetness. With that text width/height thing fixed, I may be able to use my project in the new versions now. ^^ Let's just see if everything works the way it should...

Um... wait... Seems to be a problem with trying to get a sound to play. I can import and preview a sound just fine, but the problem arises when I try to go into events, double-click the AudioX object, and then tell it to play a resource, or music, and it shows me the dropbox to select which sound effect or music from the available resources. Nothing shows up. o_O What's wrong? I don't get it... I can't imagine there's something wrong with how I'm doing things or anything...
B
4
S
2
G
4
Posts: 164
Reputation: 1,878

Post » Sat Jan 02, 2010 12:35 am

Please report any issues you're having to the tracker.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Sat Jan 02, 2010 12:50 pm

I tested it for 20 min. Seems that collision bug no longer exisits. Thank you so much. Now I can carry on my project and game.
B
1
G
3
Posts: 5
Reputation: 835

Post » Mon Jan 04, 2010 10:48 pm

Gah i still cannot get the canvas resizing stuff to work right, would someone pretty experienced with construct give me a hand in sorting it out for my app? Give me a PM :)
B
3
S
2
G
5
Posts: 301
Reputation: 2,302

PreviousNext

Return to Construct Classic Discussion

Who is online

Users browsing this forum: No registered users and 3 guests