Construct 0.99.83 released (unstable)

New releases and general discussions.

Post » Sun Feb 21, 2010 11:33 pm

[size=200:1gxw9qp6]Download Construct 0.99.83 (unstable)[/size:1gxw9qp6]
[size=85:1gxw9qp6]This is an unstable build. You can help Construct's development by downloading it, trying it out, testing and reporting bugs. If you have projects you want to work on without possible bugs getting in the way, stick to stable builds.
Link to previous build (0.99.82) changelog[/size:1gxw9qp6]

This is an unfinished build so is unlikely to be a stable candidate. I think Davo has moved and I haven't been able to get through to him for a while, and these fixes have been sitting around, so I'm releasing them for testing in the meanwhile. I don't think we've fixed absolutely everything we wanted to get done for the next build, but give it a try and see if we missed anything.

[size=150:1gxw9qp6]Changelog[/size:1gxw9qp6]
Event Sheet Editor
[FIX] - Fixed dragging events disappearing in the situation where an object was refered to a paramer (eg. System Compare Sprite.X < 0)
[FIX] - System object "object overlaps/collides with point" displayed parameters incorrectly (even though it functioned correctly)

Behaviors
[FIX] - Platform Movement - Been working really hard on bug checking it. This version should be even more stable.
[FIX] - Physics 'Set immovable' and 'Set rotations disabled' had inverted logic (set immovable would set movable etc). The names have been switched around to reflect what it's really doing (only the names have changed, not the functionality, caps won't need changing)

Plugins
[ADD] - Tiled background now has z elevation like sprite does :D
[FIX] - Plasma renders the 'cuttoff' correctly like the 0.98.x versions
[FIX] - Messagebox: 'Compare ID' took no parameter
[FIX] - Array: Compare conditions didn't work properly with one of the coordinates being 1

Runtime
[FIX] - Fine collision against box collision was calculated incorrectly.
[CHANGE] - Changed some family code back which fixes the issues people have been having with families in recent builds. However, this probably reopens a bug with the Family.Count expression returning incorrect counts. This will be left as a known issue for the time being since it is a less severe problem.
[FIX] - The pixelHeight parameter passed to shaders was calculated incorrectly sometimes.

Effects
[FIX] - A lot of effects (20) have been modified to support alpha testing. This means if you have a 3d box thats coming out of the water and you apply a distortion effect to that water, the part of the 3d box that emerges out of the water wont be affected.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Sun Feb 21, 2010 11:34 pm

Awesome, all seems fine this end!
B
3
S
2
G
3
Posts: 628
Reputation: 2,531

Post » Mon Feb 22, 2010 12:34 am

Ashley, it appears that the platform behavior fixes David made in his test build didn't make it into this release. I'm thinking you either included or built the wrong platform runtime, because all the old .82 bugs are still there.

If I copy the .83 platform runtime from his Stuff.rar into this release's plugin runtime folder then it works fine.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Mon Feb 22, 2010 12:52 am

Ah OK, I guess David didn't submit his final platform changes. I'll make sure they get in to the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Mon Feb 22, 2010 12:55 am

Okay then, but that means Platform School is still on hiatus. It pretty much needs those fixes to work properly.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Mon Feb 22, 2010 2:49 am

Have 3D boxes been fixed?
B
2
S
2
G
2
Posts: 372
Reputation: 1,794

Post » Mon Feb 22, 2010 3:30 am

I don't know, have they? Which bug are you referring to?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Mon Feb 22, 2010 5:46 am

The addition of a z setting for tiled backgrounds should be cool for doing maps.
Probably pretty good for first person shooters too.
Image Image
B
161
S
48
G
90
Posts: 7,356
Reputation: 66,767

Post » Mon Feb 22, 2010 8:42 am

Thanks, my game works again! Jumping from 99.70 :)
B
30
S
15
G
10
Posts: 285
Reputation: 7,144

Post » Mon Feb 22, 2010 1:44 pm

Just tried to run an old cap and found the crispify shader is missing.

How long has that been gone, and is it going to come back?

Krush.
B
2
S
2
G
3
Posts: 406
Reputation: 2,062

Next

Return to Construct Classic Discussion

Who is online

Users browsing this forum: No registered users and 4 guests