Construct 2 Auto-Backups Seem To Be Broken/Useless Currently

Bugs will be moved here once resolved.

Post » Wed Jun 15, 2016 1:52 am

Problem Description
Since my huge projects autosave is corrupted I enabled manual saving meaning, I disabled auto-saving.
However autobackups are still on, I run one backup every 15 minutes and another one every 30 minutes.
The problem with backups which are basically just the same project saved on different locations,
do not work without actually saving the game manually.
This is a huge disadvantage for people like me that have to deal with constant overheating BSODs.
(AMD core masterrace...)

Attach a Capx
Useless capx (Just following the quidelines even though this is an engine based issue.)

Steps to Reproduce Bug
  • Disable autosaving and enable autobackups
  • Do not manually save the project
  • Notice that no autobackups are being done even though they are set to every XX minutes.

Observed Result
No backups are being done even though they should be
because they are relying on the actual project saving mechanism.

Expected Result
Autobackups should work like autosaves and stop the project to autobackup.
I expect autobackups to be a way of "brute" saving content without it relying on the project saving mechanics.

Operating System and Service Pack
Windows 7 with latest updates and up to date drivers.

Construct 2 Version ID
Newest release r229 Steam release. [Personal Edition]
ImageImageImage
B
63
S
23
G
78
Posts: 661
Reputation: 44,935

Post » Tue Jun 21, 2016 11:01 am

This is by design and documented:

Note: backups are only made when pressing the 'Save' button. Simply opening a project that somebody has sent you will not make a backup for it unless you modify it and click 'Save'.


In other words, autobackup means "upon save, make backup if time since last backup is longer than the interval given". Autosave is meant to be the mechanism to trigger that on a regular basis automatically without having to press save, so closing as won't fix.
Scirra Founder
B
398
S
236
G
88
Posts: 24,433
Reputation: 194,635

Post » Tue Jun 21, 2016 1:12 pm

Ashley wrote:This is by design and documented:

Note: backups are only made when pressing the 'Save' button. Simply opening a project that somebody has sent you will not make a backup for it unless you modify it and click 'Save'.


In other words, autobackup means "upon save, make backup if time since last backup is longer than the interval given". Autosave is meant to be the mechanism to trigger that on a regular basis automatically without having to press save, so closing as won't fix.

Understood but Ashley you have to understand that I'm really in the need of a working automated saving system.

I know I'm beating a dead horse with the following again because it has been reported a few times in the past.
Could you please try to implement some sort of workaround for broken autosaves?
I know that a moderator will immediately tell me to create another report just for this bug again but as many people with the same problem already said,
there is no way to reproduce this bug so it wouldn't be fair to create another bugreport without a way to reproduce in the forums that just ends up dead like the ones before did.

If you have any and I mean any way to fix it by deleting files or manipulating something inside C2 autosaving mechanism, please tell me that as soon as possible.
Otherwise I would like to suggest some sort of system to reset broken autosaves,
this is the only project-breaking bug left and with this one out of the way I would consider C2 to be the perfect game engine for me at least.

EDIT:
Report HERE
ImageImageImage
B
63
S
23
G
78
Posts: 661
Reputation: 44,935


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 8 guests