Construct 2 Crash when duplicating and opening a new layer

Discussion and feedback on Construct 2

Post » Mon Jun 09, 2014 9:37 pm

When I duplicate an existing layout and upon opening that newly created layout, Construct 2 crashes. I can replicate this even on an empty new project. Does anyone have any clues? Construct 2 has been reliable for me up to this point. I am even using version 168. Thanks in advance.
Last edited by ACAdapter on Mon Jun 09, 2014 11:46 pm, edited 1 time in total.
B
4
S
1
Posts: 2
Reputation: 474

Post » Mon Jun 09, 2014 9:58 pm

Unfortunately I'm on r171, but I can say that it doesn't crash when I duplicate a Layout (I assume you meant Layout rather than Layer).

Have you tried re-installing, or even try the latest beta?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,545
Reputation: 60,434

Post » Mon Jun 09, 2014 11:51 pm

Yeah, I tried updating to r171 and it still does not work. FYI, I am using a Windows Vista. Also, I didn't try to re-install because I thought the updating would fix that. Should I uninstall completely then install it back? Thanks.
B
4
S
1
Posts: 2
Reputation: 474

Post » Tue Jun 10, 2014 6:43 am

Best bet is to try a clean install.

Uninstall current C2, reboot, then move or delete (just move if you want to keep existing plugins) the remnants of the previous C2 installation. This is to clear out any possible corrupt or broken plugins.

If at all possible, see if there is any updates to your OS and graphics card.

Install either r168 or r171 and open one of the templates. Try duplicating a Layout.

If it still crashes, then there is more than likely something amiss with the OS or graphic drivers, but that would need a full OS rebuild to fully check, which is wouldn't be nice.

Others may have other ideas, but considering how many users use C2, and this hasn't been reported before, it's more than likely an issue with your system.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,545
Reputation: 60,434

Post » Tue Jun 10, 2014 7:08 am

Check your graphics card drivers are up-to-date.
Scirra Founder
B
402
S
238
G
89
Posts: 24,628
Reputation: 196,023


Return to Construct 2 General

Who is online

Users browsing this forum: SaRaB and 1 guest