Construct 2 crashed when opening a capx project

Discussion and feedback on Construct 2

Post » Thu May 08, 2014 8:55 am

Hi,

I am running Construct 2 on OSX via Parallel Desktop on Windows 8. About 6 months ago, everything worked fine. After a while, I start working on some Construct 2 projects again. However, when I tried to open an existing project, Construct 2 crashed. I tried to download the latest version and run it again, but it didn't help.

Here is the error message I got when it crashed:

Code: Select all
Problem signature:
  Problem Event Name:   APPCRASH
  Application Name:   Construct2.exe
  Application Version:   2.0.0.0
  Application Timestamp:   53590e4c
  Fault Module Name:   Construct2.exe
  Fault Module Version:   2.0.0.0
  Fault Module Timestamp:   53590e4c
  Exception Code:   c0000005
  Exception Offset:   000000000040dbfe
  OS Version:   6.2.9200.2.0.0.256.48
  Locale ID:   1033
  Additional Information 1:   4d12
  Additional Information 2:   4d12f30b6679751009705f2eb1fafaef
  Additional Information 3:   3e16
  Additional Information 4:   3e16874850c852661f6c7b9583bac147

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=190175

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt


Anyone knows if Construct 2 made any change that prevents running Construct 2 on Mac or not? Or, does anyone run it on Mac at the moment?

I hope that there is some ways to run it on Mac using Parallel Desktop as I don't have pure Windows at the moment.

Thanks.
B
10
S
4
G
2
Posts: 36
Reputation: 2,207

Post » Tue Jul 01, 2014 2:37 pm

Tell @Ashley, he may know what to do.
B
103
S
24
G
11
Posts: 695
Reputation: 12,884

Post » Wed Jul 02, 2014 10:52 am

Well, I spent lots of time working on this issue. Seems like when I run Construct 2 on Mac via Parallel Desktop, the graphic driver is not recognised.
B
10
S
4
G
2
Posts: 36
Reputation: 2,207

Post » Wed Jul 02, 2014 11:05 am

Have you tried it on windows 7? Last time i try to launch construct 2 in parallels, it works fine with 7.
B
22
S
9
G
7
Posts: 421
Reputation: 6,543

Post » Wed Jul 02, 2014 11:46 am

A year ago it also worked fine on my Windows 8 via Parallel Desktop. Don't know why it doesn't work anymore. If it is possible, I prefer using Windows 8 as it is much more lighter. Otherwise, maybe I have to switch back to Windows 7 then.

Are you able to try to run Construct 2 on Win 8 via Parallel?

Thanks.
B
10
S
4
G
2
Posts: 36
Reputation: 2,207

Post » Wed Jul 02, 2014 1:39 pm

detno29 wrote:A year ago it also worked fine on my Windows 8 via Parallel Desktop. Don't know why it doesn't work anymore. If it is possible, I prefer using Windows 8 as it is much more lighter. Otherwise, maybe I have to switch back to Windows 7 then.

Are you able to try to run Construct 2 on Win 8 via Parallel?

Thanks.

Sorry, i don't use vm's anymore, i have win8 as a second OS on my mac and construct2 works good, so i dont think that the problem is in c2, but, i found that you're not the first person who got video driver crash on parallel desktop. Try google "parallels driver crash", i found that some apps are really crashing on parallel win8, dunno why. Maybe try to ask the parallels support team, or just install win8 as second OS. Oh, and have you try to just reinstall your vm? Maybe this will help.
B
22
S
9
G
7
Posts: 421
Reputation: 6,543

Post » Wed Jul 02, 2014 9:15 pm

Sisyphus wrote:Sorry, i don't use vm's anymore, i have win8 as a second OS on my mac and construct2 works good, so i dont think that the problem is in c2, but, i found that you're not the first person who got video driver crash on parallel desktop. Try google "parallels driver crash", i found that some apps are really crashing on parallel win8, dunno why. Maybe try to ask the parallels support team, or just install win8 as second OS. Oh, and have you try to just reinstall your vm? Maybe this will help.


Thanks for your answer. According to what you are saying, I assume that you are running Windows on Mac via bootcamp, aren't you?

I am thinking about re-install the VM as well but got lots of stuff on Windows so I don't want to spend time backing it up and restoring it. :)
B
10
S
4
G
2
Posts: 36
Reputation: 2,207

Post » Thu Jul 03, 2014 9:33 am

detno29 wrote:
Sisyphus wrote:Sorry, i don't use vm's anymore, i have win8 as a second OS on my mac and construct2 works good, so i dont think that the problem is in c2, but, i found that you're not the first person who got video driver crash on parallel desktop. Try google "parallels driver crash", i found that some apps are really crashing on parallel win8, dunno why. Maybe try to ask the parallels support team, or just install win8 as second OS. Oh, and have you try to just reinstall your vm? Maybe this will help.


Thanks for your answer. According to what you are saying, I assume that you are running Windows on Mac via bootcamp, aren't you?

I am thinking about re-install the VM as well but got lots of stuff on Windows so I don't want to spend time backing it up and restoring it. :)

Yeah, i spend about 5 minutes to install windows via bootcamp, and that's surely better than messing with the vm's for me, because i have mbp 13, and when i use vm soft, i got to recharge it every 4 hours, not good for me, because in osx without vm, it's working about 9 hours and in win8 about 6.
B
22
S
9
G
7
Posts: 421
Reputation: 6,543

Post » Wed Jul 30, 2014 12:49 pm

Sorry, I'm late to the party...but I've run into the same issue. One (annoying) workaround I've found...within Windows 8 on Parallels, open up your Device Manager. Under Display Adapters, you should see something along the lines of "Parallels Display Adapter"...right click and disable it.

Your window may go wonky, but you can open up your capx. Once the capx is opened, you can re-enable the display adapter. You'll need to disable the adapter every time you open or create a new capx.
B
15
S
2
Posts: 10
Reputation: 822


Return to Construct 2 General

Who is online

Users browsing this forum: JaredX, megatronx and 1 guest