Construct 2 Crashes when clicking below Properties

Bugs will be moved here once resolved.

Post » Thu Jan 31, 2013 12:50 am

[QUOTE=Ashley] I still can't reproduce this. Can you tell me precisely the exact sequence of clicks you use after opening a new project?[/QUOTE]
I've just discovered how to more easily recreate this problem. Ramones actually made me think of it with what he said:
[QUOTE=ramones]...if I have more than one object selected and I click in the white area below properties or on the grey margin to the left of the properties. It doesn't crash if I've only a single object selected and I click there.[/QUOTE]
I mentioned that this crash only occurs when I had a sprite selected in the projects tab on the right dock, and then clicked somewhere in the left dock's properties tab below "More Information | Help". What I didn't take into account, is whether or not selecting a sprite in the Projects tab also highlights/selects all of those sprites in the layout. It does, and if you have more than one of that sprite anywhere in your layout, you will crash when clicking in the mentioned location. It doesn't happen for me if I only have one instance of that sprite placed in the layout.

Like So:



The exact clicks to reproduce this error from scratch, without a capx example, would be:
    Open Construct 2 r114/r116/r117 by double clicking a desktop shortcut,
    left click File (or the file button rather),
    left click New,
    left click New Empty Project,
    right click "Object types" in the Projects Tab,
    left click "Insert new object",
    double click Sprite,
    left click anywhere on the layout to place it,
    Exit out of "Edit image" window that should pop-up,
    Ctrl+C to copy the sprite already selected,
    Ctrl+V to initiate pasting duplicate sprite,
    left click anywhere else on the layout,
    left click the Sprite listing under "Object types" in your Projects tab,
    left click anywhere below "More information | Help on the left,
    Construct 2 should crash and create the stopped working window.


This happens on any project I've opened where a sprite has more than one instance in the layout, and that area is clicked.
[QUOTE=Ashley]Can anyone else reproduce this? Maybe it's specific to Windows XP (I tried on Windows 8)[/QUOTE]
Actually, it looks like out of the 3 other posts in this topic which claim they've experienced this, only one of them had Windows XP, the other two were using Windows 7 SP1 64-bit like myself.
[QUOTE=Kyatric]Keep your work safe with C2's backup options ?[/QUOTE]
...How in the world did I miss that when I read the manual, good grief. Thanks Kyatric, been reading your helpful replies in topics for a while now. /Insert "feels like a fool" sentence.

EDIT: Just checked to see if clicking anywhere else can cause the crash as well. Had no luck except for one spot.. clicking anywhere to the left of the properties tab on the edge of the screen/window.. probably only a one-to-few pixel-wide spot which is just as deadly all the way down the side of the tab.

Sounds to me like Construct doesn't know what to do when attempting to deselect from multiple sprites (by clicking an area that doesn't have any backboard-like coded response as to how to de-select them, like when you click off them in the layout? It has no problem deselecting a property after editing it, but using that spot to deselect the sprites?: No good.Demetari2013-01-31 11:10:30
B
3
Posts: 8
Reputation: 466

Post » Thu Jan 31, 2013 9:19 am

Demetari, huh, just tried this and it crashes on my pc too, Win7 64 :D
B
78
S
23
G
6
Posts: 234
Reputation: 7,662

Post » Thu Jan 31, 2013 9:20 am

I originally missed the step about highlighting the 'cloud' sprite in the top left Projects tab, before clicking in the empty area. It now does indeed crash every time for me.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,841
Reputation: 48,283

Post » Thu Jan 31, 2013 9:51 am

After selecting the "Cloud" object type in the project's tab (in the original capx), I've had to click + double click the white area under the "More informations|help" to experience the crash.
Though since, it reproduces consistently (open the capx, select "Clouds", double click => crash).

[QUOTE=Demetari]Insert "feels like a fool" sentence.[/QUOTE]
Well don't, not noticing features has happened to all of us at least once.
It's just sad it has caused you to lose work on a project before noticing it.Kyatric2013-01-31 09:52:10
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791

Post » Thu Jan 31, 2013 10:36 am

[QUOTE=Kyatric]I've had to click + double click the white area under the "More informations|help" to experience the crash.[/QUOTE]
Yes, sometimes it happens on only a single click (such as when I'm at my most vulnerable), or sometimes it takes multiple clicks (when I'm trying to reproduce it purposefully, of course)

I'm somewhat relieved to hear that it isn't turning out to be only my particular setup which is allowing the crash... Perhaps this problem can be fixed in a future release. Until then, I will enjoy the auto-backups now, and fret much less.Demetari2013-01-31 11:10:04
B
3
Posts: 8
Reputation: 466

Post » Thu Jan 31, 2013 7:30 pm

I've been able to replicate this on a Windows 8 machine with Intel graphics as well.
B
54
S
28
G
18
Posts: 1,520
Reputation: 24,990

Post » Mon Feb 04, 2013 1:46 pm

I still can't reproduce any issue on Windows 8 either from the original .capx or from the steps from a new project. Seems to work fine even when clicking like mad in the properties bar. Not sure what to do about this since I can't repro...
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,518

Post » Thu Feb 07, 2013 8:22 pm

I have a similar bug, but it happens when I'm changing an object properties, like the height and width of an array. But I can't reproduce it consistently so I wont report it >:
B
83
S
21
G
15
Posts: 1,039
Reputation: 15,134

Post » Fri Feb 08, 2013 10:28 am

I just did it too with space blaster, I duplicated the "player" sprite and selected it via projects tab under objects. Both highlighted. then I had to scroll down the scroll bar in the properties window, and like Kyatric, first click didn't seem to do anything, but then I clicked to drag across it with my mouse and it crashed before I could start the drag.

Still using r116 64bit on this win7 machine.

Edit: Ok, Windows 8 r117 does it too. Single click, and wait a sec.

(kinda like the guy who went to the doc saying it hurts when I do this, and the doc said "stop doing that.")Paradox2013-02-08 10:43:06
B
200
S
51
G
30
Posts: 896
Reputation: 36,494

Post » Fri Feb 08, 2013 1:54 pm

@Paradox - followed your instructions, still can't reproduce. On Windows 8 here. Normally my properties grid is tall enough not to need scrolling, but I tried with the window resized down so I also have to scroll, still no issue here.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,518

PreviousNext

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest