Construct 2 hard crash on Layout

Bugs will be moved here once resolved.

Post » Mon Mar 25, 2013 6:57 pm

Link to .capx file (required!):
All .capx, including fresh projects

Steps to reproduce:
1. Launch Construct 2
2. Load or create a new project
3. Click Layout
4. Crash

Observed result:
Hard crash

Expected result:
Layout view

Browsers affected:
N/A

Operating system & service pack:
Windows 7 Ultimate x64 SP1

Construct 2 version:
123.2 (All recent previous versions)

More information:
I've updated my video drivers, both to current, and to most recent beta, with no change in behavior. I run an AMD based system, Phenom and HD5870. I've uninstalled and reinstalled various versions of construct 2, from old known stable builds to most recent betas, which no change in behavior. I've installed to different drives, removed all instances of Construct in the registry, and installed each attempted version in both 32-bit and 64-bit, all with no change in behavior. A few of the example projects load directly into the Event Sheet, and when they do, I am able to edit and run the project. The application, again, immediately crashes as soon as I click "Layout 1" in this scenario.

Prease, halp!thedrcoma2013-03-25 18:58:25
B
2
Posts: 3
Reputation: 306

Post » Mon Mar 25, 2013 9:19 pm

It's a graphics card driver issue. It's possible the latest drivers still crash your computer, in which case AMD have totally screwed you. Sorry, there's nothing we can do to fix this.
Scirra Founder
B
358
S
214
G
72
Posts: 22,946
Reputation: 178,333

Post » Mon Mar 25, 2013 9:26 pm

Balls. Getting really tired of AMD. Any suggestions regarding which driver version to run? Or is it simply going to be an exercise in trial and error?
B
2
Posts: 3
Reputation: 306

Post » Mon Mar 25, 2013 9:36 pm

The very latest, but you said already that doesn't work. Maybe make your next graphics card a nVidia.
Scirra Founder
B
358
S
214
G
72
Posts: 22,946
Reputation: 178,333

Post » Sat Mar 30, 2013 5:01 pm

Just a quick little update - I managed to get it working. Apparently LogMeIn's Mirror driver was causing the conflict with Construct; removing all variations of the driver stack and the software fixed the crash issue.thedrcoma2013-03-30 17:01:56
B
2
Posts: 3
Reputation: 306


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests