construct 2 R178 crashes when opening a layout

Bugs will be moved here once resolved.

Post » Sat Aug 23, 2014 8:51 pm

Problem Description
When I tried to open a layout I closed construct 2 crashes. I didn't not experience this with R177. Actually this is the 1st time I'm seeing c2 crashing.

Attach a Capx
____ done that____

Description of Capx
The capx file is just a new empty project with nothing but just empty layouts and empty event sheets

Steps to Reproduce Bug
[list]
[*] Step 1 Create a new project
[*] Step 2 Create more than one layout
[*] Step 3 close one of the layouts and try to open it again (by double clicking on it)
Step 4 C2 crashes and exits to desktop or any other program covering the desktop.

Observed Result
It shows a windows crash message and that's it.....
The problem signature/ details

Problem signature:
Problem Event Name: APPCRASH
Application Name: Construct2.exe
Application Version: 2.0.0.0
Application Timestamp: 53f393a2
Fault Module Name: Construct2.exe
Fault Module Version: 2.0.0.0
Fault Module Timestamp: 53f393a2
Exception Code: c0000005
Exception Offset: 0006bfda
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
Additional Information 1: 476c
Additional Information 2: 476c972d953eeefbea1b80bc455a3d35
Additional Information 3: 01a7
Additional Information 4: 01a759a6d1b38c063289090cd07432f5

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid= ... cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt




Expected Result
Just like in R177, it was supposed to open the layout when the layout is double clicked

Affected Browsers
At this point it isn't a browser related problem, the game i was making with my other project runs smoothly on chrome and firefox.

Operating System and Service Pack
windows 7 ultimate (sp1 or 2 i guess)

Construct 2 Version ID
R178
You do not have the required permissions to view the files attached to this post.
B
5
Posts: 3
Reputation: 233

Post » Sat Aug 23, 2014 9:06 pm

Followed your instructions and it doesn't crash for me.

Tried with your attached .capx and that didn't crash either.

I'm using 64 bit version of r178 and Windows 7.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
84
Posts: 5,388
Reputation: 58,458

Post » Sat Aug 23, 2014 9:10 pm

Thanks...I guess it's my computer then. I will restart it and try again.
B
5
Posts: 3
Reputation: 233

Post » Sat Aug 23, 2014 9:13 pm

It could be many things :) It's still possible that C2 could be the issue, i.e. a faulty installation.

Have you installed any updates recently to either your OS or your GFX card?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
84
Posts: 5,388
Reputation: 58,458

Post » Sat Aug 23, 2014 9:22 pm

It's not C2. I've figured it out. C2 works well with windows aero theme.I disable windows aero when i was doing a screencast. I switched back to an aero theme and it's now working again. I feel alive again.
B
5
Posts: 3
Reputation: 233

Post » Tue Aug 26, 2014 3:16 pm

Closing, this issue is always a graphics card driver bug, check your drivers are up to date.
Scirra Founder
B
395
S
233
G
88
Posts: 24,376
Reputation: 193,842


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 7 guests