Construct 2 refuses to close

Bugs will be moved here once resolved.

Post » Wed Jun 12, 2013 8:11 pm

Still happening here as well.
B
49
S
11
G
10
Posts: 1,833
Reputation: 14,418

Post » Sun Jun 23, 2013 3:51 am

Was just about to start a new thread when I saw this one.
Been happening to me for the past three beta updates. Including the latest r135. I can't find any patterns except for having the program open for an extended period of time. Like two or three hours +
B
50
S
14
G
12
Posts: 813
Reputation: 16,764

Post » Sun Jun 23, 2013 4:42 am

Just confirming that it still happens to me also.
B
90
S
30
G
24
Posts: 3,189
Reputation: 32,400

Post » Sun Jun 23, 2013 6:11 am

Weird. This hasn't happened to me yet, and I've been going crazy playing around with C2 the last few days. :p

Perhaps it has something to do with particular install versions of C2? Like maybe it isn't reading 64-bit system and installing the 32-bit C2 on 64-bit systems?

I honestly have no idea if anything is different with my version (free, latest beta update)

The only bug I've ever had so far is the dang alt-tab crash. :p
ImageImageImageImage
B
50
S
18
G
51
Posts: 633
Reputation: 30,021

Post » Wed Jun 26, 2013 12:53 am

I get this too, I was just checking for a solution.
The longer C2 has been open, the more likely it is to to this - that's the only pattern I can find.


Running W7 x64 with r132 64 bit version, though I don't think that matters.
B
8
S
2
G
2
Posts: 59
Reputation: 1,966

Post » Sun Jun 30, 2013 12:38 pm

Same issue. r132
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
71
S
19
G
19
Posts: 1,919
Reputation: 16,910

Post » Thu Jul 11, 2013 8:44 pm

I'll chime in. Happens to me as well, on at least 4 of my computers, Windows 7 and 8.
B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993

Post » Sat Jul 13, 2013 11:49 pm

New glitch that actually has a benefit in this situation, when it happens and Construct2 won't close, on the empty project screen press ALT-f4 and it will crash, closing the stuck program.

edit: No, it's not the same Alt f4 that was fixed, this only works after Construct is in the "stuck" state. r138Paradox2013-07-13 23:58:44
B
200
S
51
G
30
Posts: 896
Reputation: 36,494

Post » Sat Jul 20, 2013 4:52 pm

I've had the same problem since I started working with C2, the program freezes upon trying to close it, then I have to CTRL-ALT-DELETE it and then it doesn't respond. Almost never closes properly, happened regularily both on R132 Free and Personnal license, and R139 in Personnal License. I'm on Windows 7.

I also get a bunch of crashes in general, seemingly at random, so I have to save often. Maybe it's all related to the size of the file? My project has 583 Events, it's Approx. download is 34.6 MB and it's memory use is 136.7 MB.

Anyhow, I really hope this is improved sometime, the program not closing is kind of annoying, but the recurrent crashes are sometimes very upsetting; sometimes it seemed like the Ctrl+S command actually prompted the crash (not very convenient lol).

Anyways, good luck with all this hard work, thanks so much for the great program!
B
4
S
1
Posts: 7
Reputation: 705

Post » Tue Jul 23, 2013 8:10 am

Same problem here. Just tried closing it now. And it closed all open files, but didn't close the program.

Recipe up to this point:
I did leave my pc on last night and I know that ccleaner ran last night whilst I was asleep. I tried closing it now cause it wouldn't launch applications saying something about java not being something. (Still rubbing sleep out my eyes)

Something about the temp file. I presume ccleaner wiped out the temp file directory and C2 doesn't like that.

I'm drawing at straws here. Lots happens on my machine, very hard to pin point a single instance that could be the cause. But it was fine last night before bed, and now when i just sat down it gives problems. The only diff is the ccleaner clean / wipe last night.

I didn't schedule registry so that isn't it. I guess temp file missing something that C2 needs to function/close or junk system file. That is what I have... first time it has happened though.

I am finding issues with the steam version unrelated to this though. But I am running the steam version of C2 if that helps narrow down. But I guess most here aren't.


Edit: Yip I see why I couldn't launch my project files (run layout) I see all the scripts stored in temp. I won't be wiping those again whilst using program ;)

Edit: Nope ccleaner wasn't cause of C2 not closing. Just tried again and couldn't recreate it. It Closed down no problem. DUTOIT2013-07-23 09:07:12
You think you can do these things, but you can't, Nemo!
Just keep reading.
Just keep learning.
B
61
S
16
G
9
Posts: 1,429
Reputation: 12,474

PreviousNext

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 6 guests