Construct 2 refuses to close

Bugs will be moved here once resolved.

Post » Sat Oct 05, 2013 3:32 am

It still happens on r146, it happens at random for me.
B
6
Posts: 3
Reputation: 260

Post » Sat Oct 05, 2013 6:30 pm

[QUOTE=BoneyCheng] It still happens on r146, it happens at random for me.[/QUOTE]

Same here.
B
14
S
3
G
3
Posts: 93
Reputation: 1,441

Post » Mon Oct 14, 2013 7:23 pm

For all those who have AMD GPU cards, the problem may be with the Catalyst Pro Control Center software feature HydraVision.

I was having the same problem with C2 crashing and not closing both on my Windows 7 computer and my Windows 8. They both have AMD video cards and run CCC with multiple monitor connectioned. I took the approach that Ashley is correct in that it is the video card drivers. I made sure that I had the latest drivers from AMD, but the problem persisted. After lots of research I found that both Windows 7 & 8 have had problems with the ATI Catalyst Control Center software component called Hydravision that affects people using several GPU intensive programs like Photoshop and Inkscape and I found Construct 2 also.   The solution was to turn off HydraVision in the Catalyst Control Center Software. One person suggested uninstalling HydraVision software completely. I turned it off on my Win 8 machine and all the crashing stopped. It had gotten so bad that every few minutes I got a crash the more my project grew in size with more images/sprites.

My Win 8 machine has a AMD FirePro W5000 with 2gigs ram and 3 different size monitors connected. I have not tested the Win 7 machine lately. I will post results when I do.

The HydraVision feature is used to divided a monitor into multiple Desktops. I really don't need that feature,so having it turned off does not cause me a heartache at this time. AMD states that Win 8.1 should solve the problem with the CCC HydraVision feature when it is released. Hope this helps some of you with your crash problems.
B
61
S
9
G
8
Posts: 24
Reputation: 8,437

Post » Fri Oct 18, 2013 7:07 am

I got something.

I was just doing some stuff in C2 r146 64-bits Windows 7. I loaded my capx project up, create a new sprite and load an image into sprite editor, and then switch to Chrome for checking email, etc, then I left the laptop there for a while. When I came back, I closed C2. Then, voila, C2 refused to close.

[GUESS] Perhaps a pointer is missing somewhere or something during program window alt-tab switching?keroberos2013-10-18 07:08:04
I got a game that you multiply, breath fire with two heads and brawl foes to oblivion with your clones: http://www.newgrounds.com/portal/view/660664 (use Chrome on Windows for best performance)

My sites:
http://twinblazar.deviantart.com
http://twinblazar.newgrounds.com
https://twitter.com/twinblazar
http://www.pixiv.net/member.php?id=15072448
B
24
S
9
G
11
Posts: 408
Reputation: 8,040

Post » Fri Dec 06, 2013 4:43 pm

Closing since there have been no further reports since r152. Let me know if this is still an issue for anyone.
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest