Construct 2 severely lags my PC

Discussion and feedback on Construct 2

Post » Wed Sep 03, 2014 12:30 pm

Message: Wugliwu is not yet permitted to post plain text URLS (300 rep required). 1 URLS removed. Why?

found my solution for this freezing behaviour. It`s a driver problem not a C2 Problem. The last release of my Samsung AMD Dynamic Switchable Graphics Technology - Driver, was more then 2 years ago. Samsung just stopped the support for my Notebook. (Serie 7 Chronos)

The solution was the Leshcat driver: Lag and freez are gone. Iam still having this black screen effect for a second after returning to the minimized editor but that`s just gone in a blink of an eye.

But... the new driver seams to conflict with some Applications. It`s a confirmed problem with the ATI-Driver.

So to quote Ashley:
"Sometimes old hardware is no longer supported with new drivers. So they have ditched you with broken drivers and no solution. If this happens to you, don't buy from them again."

"Graphics card makers should make reliability a priority. If you are a customer looking for a new computer or graphics card, ask about or research the reliability. Nobody sells graphics cards based on reliability yet, but it's an incredibly important point, so seek out the most reliable models and vote with your wallet."

I will not buy anything from Samsung or AMD again...

I will not buy anything from Samsung or AMD again...

I will not buy anything from Samsung or AMD again...

Posts: 6
Reputation: 242

Post » Wed Sep 03, 2014 6:31 pm

try a SSD too if you dont have one. that sped up construct (and EVERYTHING) quite a bit
Posts: 393
Reputation: 6,191


Return to Construct 2 General

Who is online

Users browsing this forum: ryanrybot, Tsengar and 3 guests