Construct 2 SpriteFont - Always glitchy for me?

Discussion and feedback on Construct 2

Post » Sun Nov 10, 2013 9:50 am

@Ashley I'm already using transparent background and transparent spaces between each character. You can see it yourself when looking at the fontset image I just pasted. It seems that it's not working as you are suggesting. :-/
B
22
S
5
Posts: 107
Reputation: 2,354

Post » Sun Nov 10, 2013 11:56 am

The spritesheet you pasted earlier has a black background and the characters go right up to the edge of the cell.
Scirra Founder
B
399
S
236
G
89
Posts: 24,523
Reputation: 195,378

Post » Sun Nov 10, 2013 2:59 pm

@Ashley yeah, it's just a simple JPG export to illustrate the original image size, in response to a different question. The original image is in PNG format and has an alpha transparent backdrop.

However, the characters are aligned to the upper left corner in each character cell, despite otherwise being properly spaced. Are you suggesting that this is the source of the problem?

I can't try it out right now, but I will as soon as possible.
B
22
S
5
Posts: 107
Reputation: 2,354

Post » Sun Nov 10, 2013 3:13 pm

How does this differ to the MMF2 sprite font? I never had any issues with that... but I guess it was harder to change fonts? I can't really remember.

I know I tend not to use the C2 sprite font for words (numbers are fine). I do wish it was a little more automated. As though it calculated the character width itself and based the spacing that way, instead of me having to tweak things frequently, making sure that the gaps surrounding M's and W's are different to I's and l's.
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
82
S
13
G
7
Posts: 974
Reputation: 10,933

Post » Sun Nov 17, 2013 5:51 am

I think this might actually be a glitch after all.

Look at this image:



This is of 2 different screen shots of the same text. Note that one has a bleed over. The other, doesn't! The difference between the 2? I ever so slightly tweaked the spritefont object's size. That's all I did. All of the other settings are the same.

Wouldn't this suggest that there isn't a bleed? I have ample spacing, and used the spritefont generator, following its instructions to the letter (HA! Pun!).
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
82
S
13
G
7
Posts: 974
Reputation: 10,933

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 8 guests