Construct 2 v103 - Crash

Bugs will be moved here once resolved.

Post » Wed Sep 12, 2012 12:41 am

Here's the error I'm getting, also related to On Destroyed:
https://dl.dropbox.com/u/8367729/construct/pics/destroyError1.png

*edit*
It happens when you try to destroy more than one object at the same time.
https://dl.dropbox.com/u/8367729/construct/example/bugreport/destroyBug.capxramones2012-09-12 01:21:08
B
54
S
28
G
18
Posts: 1,520
Reputation: 24,990

Post » Wed Sep 12, 2012 2:32 am

Yeah I can't even test my game I get a similar error message, I guess it must be this destroying issue since I'm destroying heaps near the start.alspal2012-09-12 02:33:04
B
134
S
65
G
16
Posts: 1,765
Reputation: 19,188

Post » Wed Sep 12, 2012 4:35 am

i have it too. when i destroy my player on purpose i get the error
B
3
Posts: 2
Reputation: 329

Post » Wed Sep 12, 2012 4:40 am

I also have object to be destroyed at end of level same thing here
B
27
S
11
G
1
Posts: 246
Reputation: 5,048

Post » Wed Sep 12, 2012 12:51 pm

We need a .capx file to be able to solve the problem. Please share any affected .capx files on Dropbox, or email them to ashley@scirra.com if you would rather keep them private.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,508

Post » Wed Sep 12, 2012 2:16 pm

i sent you a capx that triggers the problem 100% of the times line 21 is enabled.
B
42
S
11
G
5
Posts: 446
Reputation: 6,417

Post » Wed Sep 12, 2012 2:32 pm

Hi all,

I have found and fixed an issue where the presence of an 'On destroyed' trigger would cause the errors reported. It's unfortunate that an unforeseen issue made it in to a stable release. I guess that will teach me to change code before a stable update :P

What I will do is tomorrow or Friday I will issue a 103.2 update. To avoid having to issue a whole new release, and because I think this is only affecting a minority of users who use the 'On destroyed' trigger, I will make a 'quiet' update - I will simply update the existing r103 page, but I will also set the autoupdater to update all r103 users as well so nobody is left using the old broken release.

Sorry for the trouble but hopefully this will be fully resolved shortly, and I will be more careful about code changes before a stable release next time!
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,508

Post » Wed Sep 12, 2012 5:25 pm

[QUOTE=Ashley] What I will do is tomorrow or Friday I will issue a 103.2 update. To avoid having to issue a whole new release, and because I think this is only affecting a minority of users who use the 'On destroyed' trigger, I will make a 'quiet' update - I will simply update the existing r103 page, but I will also set the autoupdater to update all r103 users as well so nobody is left using the old broken release.[/QUOTE]

Exactly what I hoped for.
B
27
S
8
G
8
Posts: 903
Reputation: 8,452

Post » Thu Sep 13, 2012 11:34 am

Same problem here - looking forward to the update :)

I get it if two objects is destroyed within about 0.05 sec or less.
B
7
S
3
Posts: 109
Reputation: 1,645

Post » Thu Sep 13, 2012 1:19 pm

I got the same problem on game load.. but it happens on random.
Krish
Hey! Did you know that you can hire me to make your games?

Click Here to See More
B
21
S
5
G
5
Posts: 391
Reputation: 5,577

PreviousNext

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest