Construct 3 - Cannot Open/Import Local Files

All closed bug reports are moved here.

Post » Tue Mar 28, 2017 10:01 pm

Problem Description
Whenever I try to open up a locally saved c3p file, C3 does nothing.
No error messages or warnings, I can select and open/import a file but after that nothing happens.

Attach a file
Download Random C3P Example

Description of file
It's just a random C3 project file.

Steps to Reproduce Bug
C3p File:
  • Click on open file from local disc
  • Select it and click open
  • Notice that nothing happens
Assets:
  • Try to import any assets (e.g. sprite image)
  • Select it and click open
  • Notice that nothing happens
Observed Result
There seems to be problem with the uploading process, no further information available.

Expected Result
I want to be able to open/import local files.

Affected Browsers
  • Chrome (latest stable)
  • NW.js (latest stable)
  • Electron (latest stable)
Operating System and Service Pack
Windows 7 with latest updates and up to date drivers.

Construct 3 Version ID
Newest version available. [Free Edition]
Last edited by TheRealDannyyy on Wed Mar 29, 2017 3:49 am, edited 2 times in total.
ImageImageImage
B
69
S
24
G
78
Posts: 694
Reputation: 45,328

Post » Tue Mar 28, 2017 10:23 pm

I got the same. Also for .capx files.
B
231
S
6
G
9
Posts: 89
Reputation: 12,913

Post » Wed Mar 29, 2017 5:37 pm

It works here: I can just drag-and-drop the .c3p file you provided in to the C3 window and it appears to open it correctly. I can also open it via "Open local file".

Do you have any browser addons installed? Does disabling them fix it?
Scirra Founder
B
402
S
238
G
89
Posts: 24,632
Reputation: 196,031

Post » Wed Mar 29, 2017 8:37 pm

Ashley wrote:It works here: I can just drag-and-drop the .c3p file you provided in to the C3 window and it appears to open it correctly. I can also open it via "Open local file".
Do you have any browser addons installed? Does disabling them fix it?

I have Adblock but it's disabled on the website and in "app mode" as well. I have also disabled Avira and the Windows firewall temporally but it didn't work as well.
As my report states, I've also tested this on NW.js (which is essentially Chrome with full access) and it didn't work there either.
I'm running on Version 57.0.2987.133 by the way, which makes it less likely that Chrome is at fault in the case.

This is honestly baffling to me since the majority of people are able open local files and import images easily.
Is there perhaps an "override" in form of a chromium arg or command line switch that I can make use of?

EDIT: Drag'n drop seems to work in non-app mode but the problem with opening/importing files still persists.
ImageImageImage
B
69
S
24
G
78
Posts: 694
Reputation: 45,328

Post » Wed Mar 29, 2017 10:00 pm

@Ashley I was able to reproduce a problem/crash by importing a file using drag'n drop, below is the hopefully useful error message.

Code: Select all
Error report information
Type: unhandled exception
File: https://editor.construct.net/r12/main.js, line 140, col 49333
Message: Uncaught TypeError: Cannot read property 'length' of undefined
Stack: TypeError: Cannot read property 'length' of undefined at ǃV.ǃF.ǃd.ǃPmF.ǃPmg (https://editor.construct.net/r12/main.js:140:49333) at HTMLDivElement.ǃPmf.addEventListener.le (https://editor.construct.net/r12/main.js:140:48052)
Construct 3 version: r12
URL: https://editor.construct.net/index.html
Date: Wed Mar 29 2017 23:57:24 GMT+0200 (Mitteleuropäische Sommerzeit)
Uptime: 103.5 s

Platform information
Browser: Chrome
Browser version: 57.0.2987.133
Browser engine: Blink
Browser architecture: 32-bit
Context: webapp
Operating system: Windows
Operating system version: 7
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1
Logical CPU cores: 4
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (NVIDIA GeForce GTX 670 Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions: EXT_color_buffer_float, EXT_disjoint_timer_query_webgl2, EXT_texture_filter_anisotropic, OES_texture_float_linear, WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context
ImageImageImage
B
69
S
24
G
78
Posts: 694
Reputation: 45,328

Post » Wed Mar 29, 2017 10:47 pm

I can open a local .c3p file just fine. However, no recent project shows up in the Recent Projects tab on start up even though I just had a project opened and saved it.
B
25
S
12
G
11
Posts: 260
Reputation: 7,923

Post » Thu Mar 30, 2017 8:17 am

I am experiencing the same issues. The odd thing is that it sometimes but very rarely works. Whether I try importing a .capx file or opening an art asset into a sprite it rarely works. And to make it even more interesting, dragging and dropping works every time.
B
43
S
24
G
20
Posts: 156
Reputation: 13,604

Post » Thu Mar 30, 2017 1:01 pm

We made a fix for this in r13. Is it working better there?
Scirra Founder
B
402
S
238
G
89
Posts: 24,632
Reputation: 196,031

Post » Thu Mar 30, 2017 1:13 pm

Bleenx wrote:I can open a local .c3p file just fine. However, no recent project shows up in the Recent Projects tab on start up even though I just had a project opened and saved it.


Recent projects can only work with either cloud saves or local browser saves. So if your using "download a copy" to save I'm afraid it won't appear there.
Scirra Employee
B
6
S
2
Posts: 135
Reputation: 928

Post » Thu Mar 30, 2017 1:31 pm

Nepeo wrote:
Bleenx wrote:I can open a local .c3p file just fine. However, no recent project shows up in the Recent Projects tab on start up even though I just had a project opened and saved it.


Recent projects can only work with either cloud saves or local browser saves. So if your using "download a copy" to save I'm afraid it won't appear there.


Well darn, that's poop. Thanks for letting me know.
B
25
S
12
G
11
Posts: 260
Reputation: 7,923

Next

Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 1 guest