Construct 3 - Random Crash When Closing Projects

All closed bug reports are moved here.

Post » Thu Mar 30, 2017 8:47 pm

Problem Description
Construct 3 sometimes crashes when closing projects, this only seems to happen with projects that had a longer uptime.

Attach a file
Download Random C3P Example

Description of file
It's just a random C3 project file that you can use for testing.

Steps to Reproduce Bug
  • Work on project for quite some time
  • Click on close project (don't save unsaved changes)
  • Notice that the editor crashes
Observed Result
The editor crashes when closing projects sometimes.

Expected Result
The project should just close as expected.

Affected Browsers:
  • Chrome (latest stable)
  • NW.js (latest stable)
Operating System and Service Pack
Windows 7 with latest updates and up to date drivers.

Construct 3 Version ID
Newest version available. [Free Edition]

Crashlog:
Code: Select all
Error report information
Type: unhandled rejection
Reason: TypeError: Cannot read property 'ǃGLL' of null
Construct 3 version: r13
URL: https://editor.construct.net/index.html
Date: Thu Mar 30 2017 22:39:31 GMT+0200 (Mitteleuropäische Sommerzeit)
Uptime: 2209 s

Platform information
Browser: Chrome
Browser version: 57.0.2987.133
Browser engine: Blink
Browser architecture: 32-bit
Context: webapp
Operating system: Windows
Operating system version: 7
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1
Logical CPU cores: 4
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (NVIDIA GeForce GTX 670 Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions: EXT_color_buffer_float, EXT_disjoint_timer_query_webgl2, EXT_texture_filter_anisotropic, OES_texture_float_linear, WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context
ImageImageImage
B
63
S
23
G
78
Posts: 664
Reputation: 44,941

Post » Thu Mar 30, 2017 8:58 pm

I think I've found a more reliable way to reproduce this crash.
Just open and close the project a couple of times.

Also worth noting that you should open and close a local project.
Some projects don't seem to have this problem at all, if you cannot reproduce it with the attached project above, feel free to try THIS one.
ImageImageImage
B
63
S
23
G
78
Posts: 664
Reputation: 44,941

Post » Fri Mar 31, 2017 10:15 am

@TheRealDannyyy

Managed to reproduce it and fixed it. Will be available in r14.

Thanks for that.
Scirra Employee
B
10
S
5
G
2
Posts: 132
Reputation: 2,356


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 2 guests