Construct becomes sluggish, then freezes after 10-15min

Bugs will be moved here once resolved.

Post » Wed Feb 10, 2016 6:19 am

TheRealDannyyy wrote:Did you mean r221 or really the old version of C2? :)

hahaha, sorry, I meant version 221. I unfortunately mixed up the digits and didn't double check it before I posted. I was hoping that the new version had something to do with the improvement and not the reinstallation of windows.

I will pick up my laptop from repairs today, If the problem still exist on that computer and they haven't formatted the drive it will be much easier to troubleshoot for me. I will post my findings here :)
Currently working on "Unsung" - an open world platform adventure for PC and Consoles. follow me on Instagram :D
B
18
S
2
G
2
Posts: 50
Reputation: 1,230

Post » Thu Feb 11, 2016 11:27 am

TheRealDannyyy wrote:At last I would like to ask a question to @Ashley about C2's theme system:
Do different themes have any impact on the performance of C2?

I don't know - maybe, but it's not our code, it comes from the UI library.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Thu Feb 11, 2016 2:09 pm

@g3nki I know that this will probably lead to nothing but could you tell me your current C2 theme selected in the preferences?
ImageImageImageImage
B
56
S
20
G
76
Posts: 634
Reputation: 43,357

Post » Thu Feb 11, 2016 4:10 pm

TheRealDannyyy wrote:@g3nki I know that this will probably lead to nothing but could you tell me your current C2 theme selected in the preferences?

It is the default theme. Everything in my current installation is set to default except "Preview Server" which is set to my local ip adress: 192.168.0.5 with port numer "50000". I got my laptop back from repairs yesterday, it is even worse than when I sent it away. With that being said, I guess we need to wait a couple of more weeks before I can troubleshoot the issue further. Currently I'm just so happy that Construct 2 works the way it is intended.
Currently working on "Unsung" - an open world platform adventure for PC and Consoles. follow me on Instagram :D
B
18
S
2
G
2
Posts: 50
Reputation: 1,230

Post » Sun Feb 14, 2016 2:27 am

I wish I could say the latest version is better, but it's not. I'm running with autosave off and it greatly reduces both the frequency of the slow-down and the severity of it, but it still happens occasionally. I would guess that there's another feature that does something similar to the autosave that conflicts with the Steam.dll (or whatever is happening). I recently upgraded to Windows 10, and it behaves the same way I remember it behaving before the upgrade. Glad yours is better, g3nki!

Here are my system details in case they can help:

Operating System: Windows 10 Home 64-bit (10.0, Build 10586) (10586.th2_release.160126-1819)
Processor: Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz (4 CPUs), ~3.5GHz
Memory: 16384MB RAM
DirectX Version: 12
Card name: NVIDIA GeForce GTX 970
Chip type: GeForce GTX 970
Display Memory: 12171 MB
Driver Version: 10.18.13.6175

Construct 2 (r221) Personal Steam version
Autosave: Off
Backup: On
Cache Icons: On
Theme: Default

Virus protection: Windows Defender
B
6
S
2
Posts: 11
Reputation: 720

Post » Wed May 25, 2016 3:27 pm

So its been a while but I think I finally found a legit way to reproduce this bug.
I recommend taking 20-30 minutes of your time to try and reproduce this bug.

At first, you require the following:

- C2 Example for measurements and sluggishness tests
- My Program that automatically requests attention every 2 seconds.
(NW.js's "request attention" seems to be broken again, so I made this instead...)
- A dual screen setup with Windows 7/8/10 (preferably 1080p on both screens)

Initial steps to reproduce sluggishness:
1. Open the Capx file with the latest Steam release of C2 (preferably paid)
2. Maximize the C2 window on your main screen and set the project windows to something like THIS.
(It doesn't really matter, just make sure that there is a lot on screen.)
3. Open any unmaximized second window which requires a lot of resources on the 2nd screen.
(YT videos etc. or use the debug preview and create a lot of sprite instances using the 'space' key.)
4. Open my "Request Attention" program and also run it on the second window.
5. By now you should notice that C2 will be sluggish because of the heavy load on the 2nd screen,
keep on adding/removing events or change values and try to act like you would work on the project.
At some point you will also notice that it will take up to 1 second just to open the dialogs or change ACE values.
This is the moment were you can basically close all the programs on the second window and run C2 normally,
it will continue being sluggish even without heavy load in the background.

Final Thoughts (+problem speculations)
I took a day of from working on my project just to create this "working" test and I would really appreciate it
if @Ashley or others from the community would take their time to run this test and try to reproduce this bug too.
I am still not 100% sure why C2 is affected by this but my guess is that the engine might get "confused" at some point because of the sluggishness and starts creating some sort of "trash data" which leads to even more sluggishness.

The following might be a little off-topic but I'm really desperate about this weird Windows issue for a while now.
I noticed that whenever a program on my second window requests attention (eg. the Steam chat), my programs on the main window start to suffer from sluggishness until I stop it from requesting. (C2 is the only program that continues to suffer even after stopping the request.)
I've Googled through A LOT of forums to find a fix for this issue, so far without any working results.
@Ashley I know that you are a top-level expert when it comes to Windows & Web technology so if you got any ways to help me out on this,
feel free to PM me with anything that could help me to fix this issue once and for all.

Thanks for reading, looking forward to your results!
ImageImageImageImage
B
56
S
20
G
76
Posts: 634
Reputation: 43,357

Post » Wed May 25, 2016 4:32 pm

Does the new option to completely disable unique icons in r229 help? (it reverts all Sprite/Tiled Background etc to their plugin icons)
It might be GDI playing up again. It's a pretty crappy part of Windows.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Wed May 25, 2016 4:45 pm

Ashley wrote:Does the new option to completely disable unique icons in r229 help? (it reverts all Sprite/Tiled Background etc to their plugin icons)
It might be GDI playing up again. It's a pretty crappy part of Windows.

Great timing with the update, I will test it out.
I will do some testing with my stresstest and my main game, I'll share the results soon.
ImageImageImageImage
B
56
S
20
G
76
Posts: 634
Reputation: 43,357

Post » Wed May 25, 2016 10:12 pm

So far so good, no sluggishness at all.
It seems to work better now but I will still give it some time and share the results at the end of the month again.
@Ashley thanks for this surprising update, I really didn't expect that.
ImageImageImageImage
B
56
S
20
G
76
Posts: 634
Reputation: 43,357

Post » Thu May 26, 2016 7:48 am

@TheRealDannyyy - Have you tried opening a big project with C2 r229? I get a lot of errors and very significant lag & slowness on projects with a lot of objects on r229 but fast on r228.
Image



The Things you can create is only limited by your imagination. If you don't have the skills then use your motivation as a natural force to exceed all expectations. Chadori RebornXD
B
55
S
17
G
90
Posts: 1,111
Reputation: 59,145

PreviousNext

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests