Construct crashed while watching God Of War 3 trailer ?:o

New releases and general discussions.

Post » Sat Feb 14, 2009 12:20 am

It has happend just 2 minutes ago. I can't say whether this was a bug or not, but thats so weird - I have had construct opened for few hours but i wasn't doing anything with it. And it has crashed while i was plaing God Of War 3 New Trailer in quicktime. well, i've looked in to the event sheet for a sec, just before watching it, but did not did any editing. I don't know what to say. Is it possible that this was a bug?
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
71
S
19
G
19
Posts: 1,919
Reputation: 16,910

Post » Sat Feb 14, 2009 2:51 am

can you get it to happen again..?
B
2
S
2
G
4
Posts: 254
Reputation: 1,958

Post » Sat Feb 14, 2009 3:33 am

invalid texture was refrenced bug right?

if so its because it glitched while regaining focus or something like that, it happens to me when i stop using construct for a while then open it up from the windows bar.
B
52
S
7
G
6
Posts: 1,945
Reputation: 7,610

Post » Sat Feb 14, 2009 1:22 pm

This is "don't know what to say". I'd go with that its your machine that is source of evil :--). Maybe graphics acceleration is involved in these strange crashes?
B
6
S
3
G
6
Posts: 219
Reputation: 3,013

Post » Sat Feb 14, 2009 1:26 pm

I'd agree with Quazi and say it's probably a VRAM issue.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Sat Feb 14, 2009 1:31 pm

I found the problem:

if (system->GetTrailerPreviewStatus("GodOfWar3"))
{
crash();
}

Seriously though, I'm not sure. It sounds like the Direct-X device is used to render the video and - perhaps by some dodgy code - not freed or passed back to Construct.
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529

Post » Sat Feb 14, 2009 3:46 pm

I'd bet this is a lost device issue. Whenever an app takes fullscreen mode it causes all other apps using DirectX to release all their textures and memory and stuff. We've coded lost device handling code for the IDE, but it may be broken. You can simulate running the fullscreen trailer just by setting your game to fullscreen mode and previewing. If you close and the IDE has crashed, that's a lost device bug. Of course reproducability is the holy grail of all bugs, so if you can get a .cap which can reliably induce this, we can get on to fixing it right away.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,498

Post » Sat Feb 14, 2009 4:52 pm

The crash also occurs after you relog into Windows XP after a period of inactivity.
B
62
S
21
G
12
Posts: 1,910
Reputation: 13,155

Post » Sat Feb 14, 2009 5:06 pm

Really? You have a .cap file that reproduces that? Can you put it on the tracker so we can fix it?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,498

Post » Sat Feb 14, 2009 5:26 pm

It seems to happen with any cap (at least with textures), the crash doesn't occur every time, but if you switch to other window other than Construct (say Firefox), switch user in Windows, then switch back and open Construct window; there is bound to be an anomaly (such as editor tabs - Layout/Event sheet - or scrolling bars disappear. But that is the editor stuff.

I'll post it on tracker with a cap where this is consistent.
B
62
S
21
G
12
Posts: 1,910
Reputation: 13,155

Next

Return to Construct Classic Discussion

Who is online

Users browsing this forum: No registered users and 3 guests