Construct crashes when opening layouts

Bugs will be moved here once resolved.

Post » Wed Jan 29, 2014 10:53 am

Link to .capx file (required! If link is blocked remove the http and www parts):
http://

Steps to reproduce:
1.
2.
3.

Observed result:
Construct 2 starts normally and can open projects, but the bar above the Layout Preview (where all the open layouts and sheets are) is black and the names of the open layouts and sheets aren't visible. Construct crashes/freezes when you click on an open layout tab, when you click on an object or when you open a layout. Also the whole layout preview isn't visible.

Expected result:


Browsers affected:
Chrome: no
Firefox: no
Internet Explorer: no

Operating system & service pack:
Windows 7 Ultimate, 64 bit.

Construct 2 version:
Tried r158 and r152.
Version r146 works perfectly.

Screenshots:



I updated my graphics driver, reinstalled it and reinstalled Construct 2 a few times. Also tried different releases (r152, r158 and r159) and restarted my laptop.
My graphics card: NVIDIA GeForce GTX 760M
B
3
Posts: 8
Reputation: 293

Post » Wed Jan 29, 2014 5:10 pm

Closing, this is always a graphics card driver problem. Double-check your driver is up to date directly from nVidia, and if it is, report the bug to them.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,250

Post » Mon Feb 10, 2014 2:00 am

How is it a graphics card driver issue?
B
2
Posts: 9
Reputation: 168

Post » Mon Feb 10, 2014 12:04 pm

@puffstream - because graphics drivers can be buggy and cause programs to crash. This *exact* issue has been reported and fixed many many times over in the past by users updating their drivers.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,250


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests