Controls delay in the Platform behavior

Discussion and feedback on Construct 2

Post » Sat May 18, 2013 4:52 pm

https://www.dropbox.com/s/1th2bye19mh0n8o/Action%20Gamemaster.capx

When I was just starting to make the game, the controls were fine and responsive, and I liked it. Then, when I started to develop the game further, that is, added a new animations engine, added upgrades and organized everything with families and groups(a GIANT thank you to Scirra for this feature, it is awesome), I noticed that every movement is a little bit delayed. It's so bad that even my "playtesters" noticed that. You might say that it happens because of that giant layout "Ship", but it was that big from the start, and I had no problems with anything. And plus, the delay already starts to exist before the "Ship" layout. Like, when you get your first explosion upgrade on Stroll0, you want to jump around and shoot those explosions around to see how cool it looks. Well, you once could. And since layouts are loaded independently, the size of the "Ship" layout isn't the case. It could be an update. So, anybody, look inside and help?
HARMLESS SIGNATURE THAT IS VIEWED BY OTHERS AS OFFENSIVE AND CONTROVERSIAL
B
14
S
3
G
3
Posts: 356
Reputation: 4,362

Post » Sat May 18, 2013 5:36 pm

Seems as responsive as ever. What browser are you testing the game in?
Image
B
225
S
27
G
13
Posts: 1,774
Reputation: 18,024

Post » Sat May 18, 2013 6:08 pm

Did you get to the part where you get the green foot, the Double Jump upgrade? Try to get up again and say how it worked out. Chrome.
HARMLESS SIGNATURE THAT IS VIEWED BY OTHERS AS OFFENSIVE AND CONTROVERSIAL
B
14
S
3
G
3
Posts: 356
Reputation: 4,362


Return to Construct 2 General

Who is online

Users browsing this forum: MatheusCastellar, TRMG and 8 guests