Cordova export issues and XDK issues

Bugs will be moved here once resolved.

Post » Wed Oct 05, 2016 9:01 pm

Problem Description
When exporting to Cordova the images do not export and the build will not work in the XDK simulator or on a test device.
Tried running a development build on an iOS 10.0.2 device with debugging and found a lot of errors in the reference to my project's data.js file.
I've contacted XDK about this issue as well.

Attach a Capx
https://www.dropbox.com/s/bqxo99it8y7eugu/Test%20Build%20with%20Export%20errors.capx?dl=0

Description of Capx
This capx exports, but doesn't export the images at all when using "Cordova" Export.
The "images" folder is empty after Cordova build.
Should load into a White background with 2-4 sprites and a minimum amount of text.


Steps to Reproduce Bug
  • Step 1 Export using Cordova to a new folder
  • Step 2 Open project in XDK
  • Step 3 Attempt to "Simulate project on iOS emulator
  • Step 4 Notice that the emulator loads to a Black Screen... Curse loudly!
  • Step 5 downsize the emulator window and notice "Unhandled Exec Call" referring to CorHttpd.startServer asking for extra parameters
  • Step 6 Click Success on the "Unhandled Exec Call" window and notice new popup that states "Error fetching data.js"... Curse More

Observed Result
Build does not emulate or run on an actual device or emulator.

Expected Result
The Game should load straight into the only Layout in the Build and allow the player to drag a line from the "Gold" sprite a set distance toward the Blue Sprite

Affected Browsers
  • Chrome: (YES/NO)
  • FireFox: (YES/NO)
  • Internet Explorer: (YES/NO)

Operating System and Service Pack
Windows 7 Pro with Service Pack 1 via Parallels Desktop on a Macbook Pro running OSX 10.11.6
XDK for Mac Version 3522

Construct 2 Version ID
Release 236 (64-bit) checked
B
7
S
1
Posts: 26
Reputation: 497

Post » Fri Oct 07, 2016 1:26 pm

Can't reproduce an empty images folder - exports just fine for me. It also works just fine for me in the iOS XDK simulator, but:
1) there's not much point using that - just test in C2 and then use the XDK to publish and test on a real device
2) if you have issues with the XDK, please report them to Intel, not us
Scirra Founder
B
399
S
236
G
89
Posts: 24,527
Reputation: 195,386

Post » Fri Oct 07, 2016 6:19 pm

Thank you for the prompt response! I believe that it has something to do with my C2 Install and how it uses the cordova exporter. tried exporting the project from a different machine and it worked fine... no broken file builds
B
7
S
1
Posts: 26
Reputation: 497

Post » Thu Jan 05, 2017 3:00 am

Ashley, I figured out this issue and has to do with the way that parallels allows you to export to the mac HDD instead of the Windows Virtual HDD. If anyone else has this issue, just know that you have to export for Cordova to your Winndows Virtual HDD and not to any Mac HDD folders and it will work just fine. Hope that this helps anyone else having this issue.
B
7
S
1
Posts: 26
Reputation: 497


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests