Corrupted capx: Project missing files

Bugs will be moved here once resolved.

Post » Sun May 25, 2014 10:05 am

Message: glennvanhyfte is not yet permitted to post plain text URLS (300 rep required). 1 URLS removed. Why?
Problem Description
____ A concise description of your problem here ____
On saving .capx as single file, then closing and reopening construct 2 r168, a dialog opens saying it is missing files
sometimes it is just the logo for when previewing, sometimes it's this:
Animation/sprites/default/000.png
either way it won't edit or preview properly and my .capx is corrupted.

Attach a Capx
____ Upload a Capx to this post ____Description of Capx
Walking animations of universal lpc sprite with layout added for entering and exiting a house and commands to use number keys: 8 up, 5 down, 4 left, 6 right, 7 create bullet (arrow) , 9 create bullet (fireball)
Steps to Reproduce Bug
    Open

Observed Result
The .capx file becomes randomly corrupted when saving, closing, and reopening
Expected Result
To be able to COMPLETE a project with it being corrupted before I'm finished
Affected Browsers
  • Chrome: (YES)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
Windows 8.1 version 6.3 (Build 9600)

Construct 2 Version ID
Construct 2 r168
You do not have the required permissions to view the files attached to this post.
B
6
S
1
Posts: 4
Reputation: 506

Post » Sun May 25, 2014 4:58 pm

Don't repeatedly create tons of bug reports for the same bug. You can edit your posts instead.
Moderator
B
94
S
33
G
33
Posts: 3,006
Reputation: 27,744

Post » Sun May 25, 2014 5:02 pm

if i made several it was unintentional. I only went back to edit it and thought i was changing the initial post
B
6
S
1
Posts: 4
Reputation: 506

Post » Sun May 25, 2014 6:01 pm

To edit your posts, click the icon that looks like a pencil in the top right of your post. Clicking back after submitting a new topic takes you back to the new topic page instead.
Moderator
B
94
S
33
G
33
Posts: 3,006
Reputation: 27,744

Post » Mon May 26, 2014 9:06 pm

ok ty, but can i get some help with this?
B
6
S
1
Posts: 4
Reputation: 506

Post » Mon May 26, 2014 9:33 pm

There is little that can be done with this as it is just a corrupted project with missing graphics. There are no steps or procedure to show how this happened, so no way for Ashley to fix. For instance, what location was the project stored? Was it on a local HD, a memory stick, an online drive or something else?

Hopefully you have setup the automatic backups.

It is possible to open this project but you will need to re-add many of the missing graphics.

** EDIT **
As the missing graphics appeared to be just dummy collision sprites, I've redone them quickly. Your .capx now opens and runs without error.
You do not have the required permissions to view the files attached to this post.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
131
S
29
G
81
Posts: 5,328
Reputation: 56,630

Post » Mon Jun 02, 2014 3:25 pm

Closing, it's an already corrupt project, there is nothing we can do without the steps to reproduce this. Make sure you turn on Construct 2's backup options and if this ever happens again you should just be able to restore a backup.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests