Couple of problems with plasma

For questions about using Classic.

Post » Tue Sep 30, 2008 6:19 am

Hey again
I'm sure you guys are aware of some of the problems with plasma, for example motion blur issues, scrolling, zooming etc
But is it possible to make it so the plasma thing doesn't 'render' when there's nothing pasted in the plasma object? cause i made a little game with lots of different effects, fire, ice, wind, radiation, invisibility, teleporting etc and if i turn motion blur on, even if nothing is happening, the frame rate just completely drops :( and on my brother's computer which is not as good as mine, even without motion blur the frame rate skips a bit
Also i'll mention most of the plasma objects i'm using have at least one effect on them too

I hoped this gets fixed :D cause it's fine being able to make an example of one effect but when there's a few on screen it goes really choppy, especially with motion blur.
I dunno if i quite got my point across so just ask me if you need me to explain anything
off to work i go :)
B
3
S
2
G
5
Posts: 351
Reputation: 2,377

Post » Tue Sep 30, 2008 10:22 am

If you make the objects invisible when they're doing nothing, they won't draw and will save the rendering time.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Tue Sep 30, 2008 12:20 pm

i did that but then when they become visible again, they preserve everything that was in them when they went invisible, i tried it with opacity instead but it still slows down
i kinda need a way to test if it's not doing anything, all i can think of at the moment is setting up some kind of timer system or something
B
3
S
2
G
5
Posts: 351
Reputation: 2,377


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 4 guests