Crash Bug and LayerName Bug(?)

For questions about using Classic.

Post » Tue Dec 07, 2010 8:02 am

First, I have a layer that I turn on and when I hit a button. (e.g. an abilities menu). This also creates a bunch of containers (4 object in each). Every time I open this menu I destroy the containers (via destroying one of the objects, which should destroy the whole thing right?) and recreate them, in case stuff has changed (got new abilitiy etc.)

If i open and close it 10 times it crashes eveyr time predictably. I can provide a cap if the answer isn't something already known but I feel like it probably is.


Second, LayerName makes everything lower case. Since layer names can be used in other contexts without being all lowr case (e.g. creating objects on a layer) this can be confusing and perhaps should be changed so that LayerName(LayerNumber) does not return the name of the layer in all lower case.
B
11
S
2
G
3
Posts: 283
Reputation: 1,968

Post » Tue Dec 07, 2010 7:59 pm

So I found this reply in another one of the topics

[quote:3t29jply]
And that bug is because scripting is enabled, 700 objects created and no scripts being run.
There are two ways to avoid that bug:
1 If you aren't using python at all but uncheck "enable scripting"
2 Just run a script every frame. It doesn't even have to do anything, a comment will work.[/quote:3t29jply]

I bet this is what's going on with my crash. Going to test it when I get home.
B
11
S
2
G
3
Posts: 283
Reputation: 1,968


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 8 guests