Crash if you open image editor w/ no layouts open

Bugs will be moved here once resolved.

Post » Thu Aug 08, 2013 7:45 am

If you open the image editor without any layouts opened you'll get an error message. After clicking OK only the animation & frame windows appear but they are blank. If you attempt to close either one C2 will crash.
Image
B
236
S
27
G
13
Posts: 1,784
Reputation: 18,329

Post » Thu Aug 08, 2013 8:13 am

I've tried to do this with 3 different .capx, but it doesn't crash for me. I'm opening a .capx, closing all the layouts, then editing and image and it works fine.

What are the exact steps you are using? Is it with all .capx or just one particular?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
129
S
29
G
74
Posts: 5,143
Reputation: 52,691

Post » Thu Aug 08, 2013 5:17 pm

I just make sure all layouts are closed, then right-click an object in the hierarchy (project window, not object window) and choose "Edit Animation".

Error message says:

---------------------------
Construct 2
---------------------------
Please open a layout before editing an object's texture.
---------------------------
OK   
---------------------------


Afterwards half the image editor opens and when I close it C2 crashes.

It's happened in every .capx in every C2 build for as long as I can remember. Just never got around to reporting it.MadFactory2013-08-08 17:21:47
Image
B
236
S
27
G
13
Posts: 1,784
Reputation: 18,329

Post » Thu Aug 08, 2013 5:32 pm

[QUOTE=MadFactory] I just make sure all layouts are closed, then right-click an object in the hierarchy (project window, not object window) and choose "Edit Animation".[/QUOTE]

Ah. That's the type of info that can change everything, however.....it still doesn't crash for me.


Have you tried resetting the dialogs, just in case one has gone walkabout?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
129
S
29
G
74
Posts: 5,143
Reputation: 52,691

Post » Thu Aug 08, 2013 5:35 pm

Well I still get the error when opening it via the object window. Tried resetting the dialogs too, didn't help.

I think it's clearly a bug else that error message wouldn't pop up..
Image
B
236
S
27
G
13
Posts: 1,784
Reputation: 18,329

Post » Thu Aug 08, 2013 9:19 pm

You're probably right, although it is very strange that it doesn't crash for me.

What version are you using? I'm using r140 beta.

Hopefully some other kind souls can try this out also before Ashley returns from his hols.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
129
S
29
G
74
Posts: 5,143
Reputation: 52,691

Post » Mon Aug 12, 2013 2:39 am

I'm interested in this. I currently cannot update any images.    It crashes every time I close the image editor.   v. 139 or r140 beta. uninstalled 2x.

I'll go try my Laptop.....
B
16
S
2
G
1
Posts: 35
Reputation: 1,033

Post » Wed Aug 14, 2013 5:24 pm

Closing, please follow the bug report guidelines. Also, I cannot reproduce any problem, it opens the image editor just fine with no layouts open.
Scirra Founder
B
382
S
222
G
84
Posts: 23,984
Reputation: 189,235


Return to Closed bugs

Who is online

Users browsing this forum: ChicaoTT and 2 guests