Crash on Load, UIState

Bugs will be moved here once resolved.

Post » Wed Sep 04, 2013 4:20 am

Link to .capx file (required!):https://dl.dropboxusercontent.com/u/122492/Public.zip

Description: Sorry to reopen this, but I have a file attached this time. As soon as it broke I copied this over.
I know this has been discussed, but there is something up with loading UIState and not handling all exceptions. When I load my project, it crashes C2 on load. If I delete all the UIState files, it loads again.

I don't know if this is linked to the age old issue of the app crashing on close.    

Steps to reproduce:
1. Open C2
2. Try and load a project
3.

Observed result:C2 Crashes

Expected result: Loads

Browsers affected: NA

Operating system & service pack: win8, win8.1

Construct 2 version: r143, r142, r141, goes back a few at least.firebelly2013-09-05 02:50:43
B
31
S
10
G
7
Posts: 416
Reputation: 7,264

Post » Thu Sep 05, 2013 2:11 pm

I cannot open the project because 1) it uses third party plugins and 2) it is missing most of the files (just a .caproj and uistate XML file, no events, layouts, images or anything else). Please re-post with a working .capx that reproduces the problem.
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,625

Post » Wed Sep 11, 2013 6:09 pm

I ran into this problem on r142. The error said ~"document is empty: [name].uistate.xml. Please check the XML file with a text editor."

The file was unreadable with a text editor. I deleted the uistate files from Event Sheets and Layouts folder. Then it worked.
B
3
Posts: 2
Reputation: 279


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests