Crash on run layout, large project

All closed bug reports are moved here.

Post » Tue Mar 28, 2017 5:16 pm

Figured I'd fire up my main C2 project and see what happens. It is a large project with currently 601 events, and works perfectly when previewed or exported from C2.
Aside from one of the tilemaps being misaligned, it loads up fine and good in the C3 editor, but I get the following crash when I attempt to run it:

Error report information
Type: unhandled rejection
Reason: TypeError: this.ǃViA is not a function
Construct 3 version: r12
URL: https://editor.construct.net/
Date: Wed Mar 29 2017 06:01:17 GMT+1300 (New Zealand Daylight Time)
Uptime: 19.8 s

Platform information
Browser: Chrome
Browser version: 57.0.2987.110
Browser engine: Blink
Browser architecture: 32-bit
Context: browser
Operating system: Windows
Operating system version: 10
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1
Logical CPU cores: 6
User agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36

WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (NVIDIA GeForce GTX 950 Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions: EXT_color_buffer_float, EXT_disjoint_timer_query_webgl2, EXT_texture_filter_anisotropic, OES_texture_float_linear, WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context

Platform information
Browser: Chrome
Browser version: 57.0.2987.110
Browser engine: Blink
Browser architecture: 32-bit
Context: browser
Operating system: Windows
Operating system version: 10
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1
Logical CPU cores: 6
User agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36

Local storage
Storage quota (approx): (status unavailable)
Storage usage (approx): (status unavailable)
Persistant storage: No

Browser support notes
This list contains missing features that are not required, but could improve performance or user experience if supported.

CSS element() is not supported.
Backdrop filters are not supported. Some UI effects are disabled.
Storage quota estimate is unavailable.
WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (NVIDIA GeForce GTX 950 Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions:

EXT_color_buffer_float
EXT_disjoint_timer_query_webgl2
EXT_texture_filter_anisotropic
OES_texture_float_linear
WEBGL_compressed_texture_s3tc
WEBGL_debug_renderer_info
WEBGL_debug_shaders
WEBGL_lose_context
Audio information
System sample rate: 44100 Hz
Output channels: 2
Output interpretation: speakers
Supported decode formats:

Ogg Opus (audio/ogg; codecs=opus)
WebM Opus (audio/webm; codecs=opus)
Ogg Vorbis (audio/ogg; codecs=vorbis)
WebM Vorbis (audio/webm; codecs=vorbis)
MPEG-4 AAC (audio/mp4; codecs=mp4a.40.5)
MP3 (audio/mpeg)
FLAC (audio/flac)
PCM WAV (audio/wav; codecs=1)
Supported encode formats:

WebM Opus (audio/webm; codecs=opus)
Video information
Supported decode formats:

WebM VP9 (video/webm; codecs=vp9)
WebM VP8 (video/webm; codecs=vp8)
Ogg Theora (video/ogg; codecs=theora)
H.264 (video/mp4; codecs=avc1.42E01E)
Supported encode formats:

WebM VP9 (video/webm; codecs=vp9)
WebM VP8 (video/webm; codecs=vp8)

I'm not willing to share the project publicly, but would be happy to send it privately if required to aid development.

Just as a minor aside, is there any way to update my username here? Would be cool if I could set it to something more "on brand" as this account is pretty old.
B
8
S
1
G
1
Posts: 12
Reputation: 1,124

Post » Tue Mar 28, 2017 8:05 pm

Take a look at your platform data.

Looks like you are using Chrome 32 on a 64 bit system. I had problems doing that so you might want to update to Chrome 64 bit version and see if that helps.

Here is a link to Chrome 64 that is working with C3:

https://www.google.com/chrome/browser/d ... form=win64
Banned User
B
28
S
7
G
58
Posts: 1,229
Reputation: 34,825

Post » Tue Mar 28, 2017 8:11 pm

Done, no change.

Error report information
Type: unhandled rejection
Reason: TypeError: this.ǃViA is not a function
Construct 3 version: r12
URL: https://editor.construct.net/
Date: Wed Mar 29 2017 09:09:01 GMT+1300 (New Zealand Daylight Time)
Uptime: 37.1 s

Platform information
Browser: Chrome
Browser version: 57.0.2987.110
Browser engine: Blink
Browser architecture: 64-bit
Context: browser
Operating system: Windows
Operating system version: 10
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1
Logical CPU cores: 6
User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36

WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (NVIDIA GeForce GTX 950 Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions: EXT_color_buffer_float, EXT_disjoint_timer_query_webgl2, EXT_texture_filter_anisotropic, OES_texture_float_linear, WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context
B
8
S
1
G
1
Posts: 12
Reputation: 1,124

Post » Tue Mar 28, 2017 8:13 pm

Well, at least you have the right Chrome version.

Does your game use any addons or plugins?
Banned User
B
28
S
7
G
58
Posts: 1,229
Reputation: 34,825

Post » Tue Mar 28, 2017 8:39 pm

None whatsoever.
Last edited by Saraqael on Wed Mar 29, 2017 6:31 pm, edited 1 time in total.
B
8
S
1
G
1
Posts: 12
Reputation: 1,124

Post » Tue Mar 28, 2017 8:48 pm

Saraqael wrote:None whatsoever.
I have the C2 export hosted here if it gives you a better idea of what I'm working with. http://platformerwip.bitballoon.com/ Arrows+ZX, or pad should work.


Hmmm?

I haven't tried C3 debugger and error code is not specific except referring to a function with no event number.

I would expect C3 to have better error reports than C2.
Banned User
B
28
S
7
G
58
Posts: 1,229
Reputation: 34,825

Post » Wed Mar 29, 2017 5:26 pm

Should be fixed in next build.
Scirra Founder
B
400
S
237
G
89
Posts: 24,550
Reputation: 195,537

Post » Fri Mar 31, 2017 2:45 pm

Confirming fixed in R14, thanks!
B
8
S
1
G
1
Posts: 12
Reputation: 1,124


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests