Crash when deleting pasted content image editor

All closed bug reports are moved here.

Post » Mon Apr 03, 2017 9:09 pm

Well, create a new project, a new sprite, It opens the image editor. Draw stuff. Copy part or all of it, paste it, then delete it. It also happens from wherever you opened the image editor, and even if you copied the content before opening the image editor.
Works with any size of copied stuff, from anywhere at anytime. The entire problem is when pressing the delete key, not about what it is deleting.
So it also happens when trying to CTRL+X after pasting (as cutting calls copy and delete).

Image

The error
Code: Select all
Error report information
Type: unhandled exception
File: https://editor.construct.net/r15/main.js, line 63, col 171546
Message: Uncaught IndexSizeError: Failed to execute 'getImageData' on 'CanvasRenderingContext2D': The source width is 0.
Stack: Error: Failed to execute 'getImageData' on 'CanvasRenderingContext2D': The source width is 0. at ee.ǃZLM.ǃZOh (https://editor.construct.net/r15/main.js:63:171546) at ee.ǃZLM.ǃZiV (https://editor.construct.net/r15/main.js:63:179138) at ee.ǃZLM.ǃZOZ (https://editor.construct.net/r15/main.js:63:169687) at ee.ǃZLM.ǃZjH (https://editor.construct.net/r15/main.js:63:169250) at ee.ǃZep.re.ǃZjp (https://editor.construct.net/r15/main.js:63:150715) at ee.ǃZji.ǃZiV (https://editor.construct.net/r15/main.js:63:200495) at ee.ǃZji.ǃZOZ (https://editor.construct.net/r15/main.js:63:169687) at ee.ǃZji.ǃZjH (https://editor.construct.net/r15/main.js:63:169250) at ee.ǃZep.re.ǃZjp (https://editor.construct.net/r15/main.js:63:150715) at ee.ǃZLV.ǃ_M (https://editor.construct.net/r15/main.js:63:269812)
Construct 3 version: r15
URL: https://editor.construct.net/index.html
Date: Mon Apr 03 2017 23:05:21 GMT+0200 (Paris, Madrid (heure d’été))
Uptime: 19.2 s

Platform information
Browser: Chrome
Browser version: 57.0.2987.133
Browser engine: Blink
Browser architecture: 64-bit
Context: webapp
Operating system: Windows
Operating system version: 10
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1
Logical CPU cores: 8
User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (NVIDIA GeForce GTX 970M Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions: EXT_color_buffer_float, EXT_disjoint_timer_query_webgl2, EXT_texture_filter_anisotropic, OES_texture_float_linear, WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context
My addons:
[PLUGIN]Value Monitor
[PLUGIN] Text Alignement
[BEHAVIOR]Timescale Ratio
[BEHAVIOR]Polar Coordinates
[PLUGIN]Action Sequence
[BEHAVIOR]Action Sequence
[BEHAVIOR]Instance Variable Control
B
35
S
6
G
2
Posts: 228
Reputation: 3,388

Post » Tue Apr 04, 2017 2:52 pm

Fixed.

You can check it out in r16 when it becomes available.
Scirra Employee
B
10
S
5
G
2
Posts: 132
Reputation: 2,356


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests