crash with familybehaviors

Bugs will be moved here once resolved.

Post » Sat May 19, 2012 11:58 pm

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

GetBehaviorInstanceFor(): object instance does not have an associated behavior instance

Condition: i != instances.end()
File: Projects\BehaviorType.cpp
Line: 183
Function: class BehaviorInstance &__cdecl BehaviorType::GetBehaviorInstanceFor(class ObjectInstance &)
Build: release 91 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------



i added solid behavior to family behaviors, first it worked, then i added an extra object to the family, when running i got this message, ignore made it crash..
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Sun May 20, 2012 6:06 pm

Same here.

Adding a new Sprite to an existing Family. Pressing 'Save' -> Bang!

(Same Message as above)

Greetings ... Peter
B
13
S
3
G
5
Posts: 9
Reputation: 4,134

Post » Mon May 21, 2012 2:14 pm

Thanks, should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,574


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests