Crosswalk Intel XDK experiences

Discussion and feedback on Construct 2

Post » Thu Nov 13, 2014 3:09 pm

The official Video plugin Works on XDK?
B
86
S
25
G
11
Posts: 652
Reputation: 11,045

Post » Sun Nov 16, 2014 8:51 pm

IntelRobert wrote:
Crosswalk 9 has the patches for the cordova vulnerability. It also has the fix for having too many images problem, which you were seeing on crosswalk 8,


@IntelRobert
Can I have as many images as I want in my project now? I just tested my project (which has 249 images) on a Samsung Galaxy Tab 3 (7") and after 15 minutes or so, the game crashed (repeatedly).
It seems pretty similar to the bug I had in the previous XDK version, when I had too many images. I've build with beta version, not stable.

I'm also still experiencing a very long black screen between my splash screen and the HTML5 loader bar. Any idea how I can get rid of it?

Thanks !
B
23
S
5
G
1
Posts: 336
Reputation: 2,408

Post » Mon Nov 17, 2014 2:37 am

Rable wrote:Can I have as many images as I want in my project now? I just tested my project (which has 249 images) on a Samsung Galaxy Tab 3 (7") and after 15 minutes or so, the game crashed (repeatedly).
It seems pretty similar to the bug I had in the previous XDK version, when I had too many images. I've build with beta version, not stable.

I'm also still experiencing a very long black screen between my splash screen and the HTML5 loader bar. Any idea how I can get rid of it?

Thanks !


I've got about 500 hundred images, it seems to run ok on lot of Android devices I've tested with beta users.

But I did have some users crash with Tab 3 7inch and also Z1, it may be related to some background app tasks still running because a memory clean will fix it.

The black screen between the splash and html5 is chromium being loaded (IIRC), its about 5 seconds.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Mon Nov 17, 2014 1:37 pm

Hello all,

I'm in the process of finishing my first Android game. I'm getting good results with XDK/Crosswalk. However, I am having some issues that other people have mentioned here (my game is not a web, it's a standalone game to be released on Google Play):-

1) Audio delay - only on certain devices.
On my Xperia Play (2.3 factory) play and Nexus 7 (Custom 4.4) - sound effects play with no delay. However, on my Samsung S4 (quad-core 4.4.2 factory) I get a very noticeable delay. I have tried different "tricks" to resolve the issue, but no joy. Is this just a Samsung/Galaxy S4 thing? Has anyone else seen this for certain devices? Just for the record, I get the delay with CocoonJS, so this looks to be a Samsung S4 thing - just not seen anyone else mention that device as being affected.

2) Lack of volume control for music.
I can get full volume control for my sound effects, but not for my music. I could define my music as sound effects (which then gives me control of the volume), but on a mobile device that will really hit the memory and I have seen it crash my device once - so that's not an option.

So, anyone has any advise on the two above issues that would be great. Other than, I really like the results I get from XDK - rock solid fps even on the old single-core Xperia Play. A small one for the wish list. Please make XDK handle fonts in the same way that CocoonJS does. Using fonts is sooooo easy with CocoonJS.
B
12
S
2
Posts: 15
Reputation: 1,084

Post » Mon Nov 17, 2014 6:34 pm

Hi there. I'm using Intel XDK for an Android game.
I've built it with Crosswalk, with Signed checked.
Now I would like to upload it on Google Play Developer Console for alpha testing, and they're asking me for the Signing certificate fingerprint (SHA1).
I need both Debug and Release certificate. Where can I get them?
B
10
S
2
G
1
Posts: 27
Reputation: 1,159

Post » Wed Nov 19, 2014 3:55 pm

Hey! I'm also using Intel XDK for an Android game. The problem that I am having is that my music does not work after publishing it on Google Play. I have read on other forums that looping sounds does not work well once published onto Google Play. Again, the music works fine of course in Construct 2 and XDK. I am limited to building it in XDK using only Android because this game is for a class and my professor told me that the game cannot exceed 10mb so I cannot use Crosswalk due to its enormous mb. I enabled all the plugins that I thought would make it work such as the "audio", "media", and "in app browser" before I built the game but that still did not solve the problem. So, if anyone has had this problem before and solved it or just know of a solution in general, please let me know.
B
3
Posts: 1
Reputation: 177

Post » Sat Nov 22, 2014 12:05 am

IntelRobert wrote:@Silverforce

Crosswalk 9 has the patches for the cordova vulnerability. It also has the fix for having too many images problem, which you were seeing on crosswalk 8,


I've updated to the most recent XDK, build with Beta Crosswalk and it's still stuck on loading bar, so I'm assuming the latest beta is Crosswalk 8.

So Crosswalk 9 in XDK is scheduled for the next release, do you have an ETA? :)
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Sun Nov 23, 2014 3:05 pm

@Drewford

Same error here! Concerning the ARM build, the loader progress bar is shown correctly, but afterwards the screen stays black and won't change at all. Does someone know how to solve this?
B
13
S
3
G
1
Posts: 91
Reputation: 1,477

Post » Sun Nov 23, 2014 4:15 pm

CreativeMind wrote:@Drewford

Same error here! Concerning the ARM build, the loader progress bar is shown correctly, but afterwards the screen stays black and won't change at all. Does someone know how to solve this?

Are you installing the app on your phone or using Bluestacks or some other type of emulator? Bluestacks was my problem. Once I started installing on my actual device, the issues were resolved.
B
34
S
10
G
4
Posts: 94
Reputation: 4,038

Post » Sun Nov 23, 2014 5:19 pm

Installed the app on my phone, did'nt work for android 4.1.1, updated to 4.1.2 and now it works.

A few other problems occured when testing the app on my smartphone. In the Intel XDK emulator, everything worked fine! The problems are:

1. The 'wait' command is much longer than expected.
2. Single frames of certain animations appear as black squares.
3. The wrapping of text inside text boxes is different from those in the emulator.

And 4.: In the emulator itself , textboxes are not located at the exact same position as in C2.
B
13
S
3
G
1
Posts: 91
Reputation: 1,477

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 7 guests