Crosswalk Intel XDK experiences

Discussion and feedback on Construct 2

Post » Tue Dec 23, 2014 11:51 am

Since the update to 1621, we have to log in to download our APK's??
B
24
S
9
G
4
Posts: 1,646
Reputation: 6,596

Post » Tue Dec 23, 2014 11:15 pm

Yes, we wanted to make it more secure.

codah wrote:Since the update to 1621, we have to log in to download our APK's??
Intel Corporation
B
15
S
3
Posts: 193
Reputation: 1,552

Post » Tue Dec 23, 2014 11:19 pm

IntelRobert wrote:Yes, we wanted to make it more secure.

codah wrote:Since the update to 1621, we have to log in to download our APK's??


I wanted to ask, for the recent update, did you guys move to Crosswalk 9 (which resolves a few issues related to security & large games)? I read the release notes but nothing is mentioned.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Tue Dec 23, 2014 11:22 pm

Beta build in XDK has been updated to crosswalk 10. We believe that rebuilding and republishing will eliminate the warning from google play. Go to the project tab, build settings, android-crosswalk tab. Under crosswalk version enter beta. Then go to the build tab, say yes when it asks you to upload, then build. Please retest your app thoroughly before publishing

IntelBrandon wrote:Potential security vulnerabilities with open OpenSSL are present if you use an older version of the library. We are aware of this issue in Crosswalk versions 7 through 9.

We will notify you as soon as we have a remedy.
Intel Corporation
B
15
S
3
Posts: 193
Reputation: 1,552

Post » Tue Dec 23, 2014 11:52 pm

I just republished an app with the latest update and the warning has gone, but I had also done the SSL reinstall that some people suggested, and I used Crosswalk stable version..
B
24
S
9
G
4
Posts: 1,646
Reputation: 6,596

Post » Wed Dec 24, 2014 3:34 am

Stable is using crosswalk 7, which has an SSL version that can trigger the message.

codah wrote:I just republished an app with the latest update and the warning has gone, but I had also done the SSL reinstall that some people suggested, and I used Crosswalk stable version..
Intel Corporation
B
15
S
3
Posts: 193
Reputation: 1,552

Post » Wed Dec 24, 2014 8:41 am

IntelRobert wrote:Stable is using crosswalk 7, which has an SSL version that can trigger the message.

codah wrote:I just republished an app with the latest update and the warning has gone, but I had also done the SSL reinstall that some people suggested, and I used Crosswalk stable version..


hmm well if I get the message I'll rebuild. Thanks.
B
24
S
9
G
4
Posts: 1,646
Reputation: 6,596

Post » Wed Dec 24, 2014 9:43 am

IntelRobert wrote:Beta build in XDK has been updated to crosswalk 10. We believe that rebuilding and republishing will eliminate the warning from google play. Go to the project tab, build settings, android-crosswalk tab. Under crosswalk version enter beta. Then go to the build tab, say yes when it asks you to upload, then build. Please retest your app thoroughly before publishing


Just tested the beta build, xwalk 10. Good news, it works, Star Nomad loads fine and runs a bit faster.

BAD NEWS. WebStorage LocalValue is reset. The old saved-game based on WebStorage is deleted, starting afresh.

Xwalk 10 must have changed the way it handles localhost, because by default, WebStorage saves the app data based on the current localhost IP & port, something like 10.0.0.7:50000 (or thereabouts). When that IP/port is changed, WebStorage cannot retrieve saved app data and thus builds a new empty one under the new IP/Port.

I can't update Star Nomad Elite since Xwalk7/8/9 has the security glitch and 8/9 (bug) doesn't load big games with lots of images.

Edit: Stable (7) remains fine for function, but still triggers security alert from Google.
Last edited by Silverforce on Thu Dec 25, 2014 10:22 pm, edited 1 time in total.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Wed Dec 24, 2014 1:29 pm

@Silverforce,

We are working on upgrading 7 with a version that will fix the SSL error. I will report back your findings about the port change though.
Intel Corporation
B
5
S
2
Posts: 133
Reputation: 871

Post » Wed Dec 24, 2014 2:40 pm

Silverforce wrote:I can't update Star Nomad Elite since Xwalk7/8/9 has the security glitch and 8/9 (bug) doesn't load big games with lots of images.


!?
I thought this "lot of images" bug was long time gone !
So I have to be careful as the final version of Healer Quest has 264 images... :-/
B
32
S
6
G
1
Posts: 352
Reputation: 2,812

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: DjPoke and 20 guests