Custom Fonts - Slow to Load?

Get help using Construct 2

Post » Thu Jun 09, 2016 11:27 am

Message: oliverj777 can only post plain text URLS until they have 500 rep. 2 URLS modified. Why?
Hello,

I've been following this tutorial to get custom fonts within my Construct2 Game:
https://www.scirra.com/tutorials/557/us ... ur-project

It works, however it seems to be very slow to load, considering its all running locally. I tried following these steps too:
custom-font_t73464

Such as changing the TextFont to change every tick, but that didn't help either.

Can anyone point me in the right direction? Thanks
B
5
S
1
Posts: 15
Reputation: 349

Post » Fri Jun 10, 2016 11:37 pm

How big is your input image? The one with all of the characters?
https://www.ravenheart.ca/home
I don't check the forums much anymore, but I will receive an email for PMs.

"Someone once told me I bite off more than I can chew...

I told them I would rather choke on greatness than nibble on mediocrity."
B
23
S
6
G
1
Posts: 1,419
Reputation: 4,857

Post » Sat Jun 11, 2016 9:00 am

gumshoe2029 wrote:How big is your input image? The one with all of the characters?


Input image? I'm using a custom web font, sorry should of mentioned that. The format it uses is .woff2 and its about 40 KB.
But the webfont is stored locally, within in the Files Folder.

Thanks.
B
5
S
1
Posts: 15
Reputation: 349

Post » Mon Jun 13, 2016 2:33 pm

Ah, you should look at using a SpriteFont. That is more performance friendly.
https://www.ravenheart.ca/home
I don't check the forums much anymore, but I will receive an email for PMs.

"Someone once told me I bite off more than I can chew...

I told them I would rather choke on greatness than nibble on mediocrity."
B
23
S
6
G
1
Posts: 1,419
Reputation: 4,857

Post » Tue Jul 18, 2017 5:56 am

spritefonts are definately allot easier to use aswell
Image
B
31
S
16
G
12
Posts: 318
Reputation: 9,854


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 29 guests