Debug Crashes [SOLVED] for now

Get help using Construct 2

Post » Sun Jun 28, 2015 1:45 am

Is there a way to track app crashes on device?

I have an app that I'm testing. Usual story. Runs fine locally, but crashes on an Android device.
Seems to be ok on Samsung S3, but lasts 5 minutes on my Galaxy Tab 4. No error, simply quits.
Runs fine in Intel XDK emulator and on the debugger.

Timed it and it crashes nearly exactly every 5 minutes after launch, which is strange as there is no function that is called every 5 minutes.

No error is reported on crash. So is there a log file stored on the device that I can access or is there an app which can log the error?
Last edited by frozenpeas on Sun Jun 28, 2015 11:32 pm, edited 1 time in total.
B
9
S
3
Posts: 146
Reputation: 1,150

Post » Sun Jun 28, 2015 9:04 am

Actually just realised that my computer has restarted 3 times when running the app preview in Chrome.
That's a complete shut down and restart.
Very strange behaviour.
B
9
S
3
Posts: 146
Reputation: 1,150

Post » Sun Jun 28, 2015 11:44 am

Not that I know how to fix it, but does it happen if you run other apps in the debugger?
B
44
S
11
G
2
Posts: 1,182
Reputation: 6,838

Post » Sun Jun 28, 2015 1:13 pm

Thanks, no just the one app is causing problems.

Profiler Shows
14 objects 60fps 5% CPU 66.4mb images webgl
Fan keeps kicking in though
B
9
S
3
Posts: 146
Reputation: 1,150

Post » Sun Jun 28, 2015 1:29 pm

You can try to share the capx
B
44
S
11
G
2
Posts: 1,182
Reputation: 6,838

Post » Sun Jun 28, 2015 10:09 pm

Turned off all banner and inter ads and now it doesn't crash.

For reference:

Unbounded scrolling: Yes
Fullscreen in browser: Scale outer
Fullscreen scaling: High Quality
Use high DPI display: Yes
Orientation: Portrait
Enable WebGL: On
Sampling: Linear
Downscaling: Medium quality

INTEL XDK
Crosswalk version 11
Cranberry admob plugin
Left Cranberry admob plugin in build (just in case I use in later)
Deleted all references to admob within app (no calls)
Exported app now runs without crashes

With admob test ads set at image only was getting less than 30 fps
Without admob getting between 50 and 60 fps

Layout size 768 x1366
Window size 768 x 1024

Very frustrating day
B
9
S
3
Posts: 146
Reputation: 1,150


Return to How do I....?

Who is online

Users browsing this forum: Fenix18, Lancifer and 52 guests