decraese particles rate

Get help using Construct 2

Post » Tue Mar 27, 2012 12:27 pm

Hi,

http://dl.dropbox.com/u/52040403/particles.capx

Please take a look to this capx.

When i test it on internet explorer it works fine.

1. click on the boy sprite.
2. particles rate will increase.
3. the boy sprite will disappear.
4. particles rate will decrease.
5. the new boy sprite will appear.

But, my problem is when i test it on firefox or export it through phonegap to android phones it's not working properly.

1. click on the boy sprite.
2. particles rate will increase.
3. the boy sprite will disappear.
4. particles rate will NOT decrease.
5. the new boy sprite will NOT appear.

Does anyone know why this is happened and is there another way to create the same effect.

Thanks in advance.
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Tue Mar 27, 2012 6:03 pm

I think my post should be under the how do i section. How can i move it please?
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Wed Mar 28, 2012 1:08 pm

It seems you wanna use a one shot particle
oneShotParticle.capx
didn't test it but should work.

Little note for @Ashley
I noticed that there wasn't a property to randomize particle rotation on creation. Also it would be interesting to have a rotation speed too (and rotation speed randomizer)
Which isn't exactly the same as the actuall angle randomizer.
Last edited by Yann on Sun Sep 14, 2014 9:17 pm, edited 1 time in total.
B
60
S
22
G
14
Posts: 1,479
Reputation: 16,346

Post » Wed Mar 28, 2012 1:43 pm

The same problem @Yann it works fine on internet explorer but doesn't work in the way on firefox or mobile.
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Wed Mar 28, 2012 2:09 pm

works the same on firefox and google chrome... didn't test on ie... I'm still on ie8 and too lazy to update that thing.
B
60
S
22
G
14
Posts: 1,479
Reputation: 16,346

Post » Wed Mar 28, 2012 2:28 pm

@Yann I test both my capx and yours on firefox and android phones but its not working unless i decrease the size of the particles to be like 500 instead of 1000. which will not hide the whole sprite :(

If the size of the particles is 1000, it works fine on ie9 (the particles appear and then disappear). but on firefox and android "exported through phonegap" (the particles will appear and stay there).

mina2012-03-29 09:26:34
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Wed Mar 28, 2012 2:46 pm

ah "exported through phonegap" ... I've never done that... Can't help you on that (: But the way I used the particle object is the way you should normally use it for an instant effect like yours.
For the rest, maybe you should try to post your issue on the bug forum.
B
60
S
22
G
14
Posts: 1,479
Reputation: 16,346

Post » Thu Mar 29, 2012 9:31 am

Thanks for ur help @Yann :)
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Thu Apr 05, 2012 11:58 am

Can u help me @Ashley with this issue. Is it a bug? if Yes, so how can i make the same effect and make it works on mobile device.mina2012-04-11 08:21:17
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Sat Apr 07, 2012 8:41 pm

Any Help please?
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Next

Return to How do I....?

Who is online

Users browsing this forum: Yahoo [Bot] and 22 guests