Decrease particles effect

Get help using Construct 2

Post » Fri Apr 20, 2012 3:26 pm

Hi,

http://dl.dropbox.com/u/52040403/particles.capx

Please take a look to this capx.

When i test it on internet explorer it works fine.

1. click on the boy sprite.
2. particles rate will increase.
3. the boy sprite will disappear.
4. particles rate will decrease.
5. the new boy sprite will appear.

But, my problem is when i test it on firefox or export it through phonegap to android phones it's not working properly.

1. click on the boy sprite.
2. particles rate will increase.
3. the boy sprite will disappear.
4. particles rate will NOT decrease.
5. the new boy sprite will NOT appear.

Does anyone know why this is happened, is it a bug! and is there any other ways to create the same effect.

Thanks in advance.
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Fri Apr 20, 2012 4:11 pm

Particle does decrease and the boy appears again in FF 11.0 and chrome 18.0.1025.162 m for me.

No bug there, check that your browsers are up to date and your graphic card drivers are up to date.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,805

Post » Fri Apr 20, 2012 9:15 pm

@Kyatric and how about testing it on android phones after export it through phonegap?
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Sat Apr 21, 2012 2:16 am

I don't have such device to test.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,805

Post » Sat Apr 21, 2012 5:08 am

@mina I do know if you have a way to load it to a personal site you can test it with android that way...thats how i have been testing mine.
B
26
S
6
G
7
Posts: 67
Reputation: 5,079

Post » Sat Apr 21, 2012 6:06 am

mina, i tried on 3 browser (Chrome, Firefox & IE) all seems to work properly.

Also i tried it on ipad, it works but really choppy (i guess that 300 particle rate with continuous spray is killing the frame rate),
maybe that's what crashing your android

I don't have android though so i can't test it out.

Instead of using particles, why not just manually overlaying a glow/spark image on top of that boy (and rotate/reduce the scale per tick to simulate similar effect)
B
34
S
13
G
8
Posts: 134
Reputation: 8,118

Post » Sat Apr 21, 2012 9:14 am

@Kyatric thanx 4 ur help :)
@cjr1974 thanx, but i don't want to test it as a web base. I want to test it as a phone application with extension of apk or other ios, symbion extensions.
@Potato Yes i think the problem is related to the particle rate. If i make it less that 500 it works fine but it will not hide the hole boy sprite. Can u post an example of ur glow/spark image idea :D
B
303
S
6
G
5
Posts: 163
Reputation: 12,152

Post » Sat Apr 21, 2012 9:41 am

mina, here's a quick modification from your capx,
not as cool as using particles,
but hopefully can give you some idea instead of using lots of particles :D

http://dl.dropbox.com/u/39382262/particleTest.capx
B
34
S
13
G
8
Posts: 134
Reputation: 8,118

Post » Sat Apr 21, 2012 9:57 am

@Potato Thanx I really appreciate ur help. It looks nice also ;)
B
303
S
6
G
5
Posts: 163
Reputation: 12,152


Return to How do I....?

Who is online

Users browsing this forum: Callan S, gamecorpstudio, Kagubro and 16 guests