Delayed Updating of Pathfinding Speed

Bugs will be moved here once resolved.

Post » Thu Feb 14, 2013 11:41 pm

Link to .capx file (required!):
http://sdrv.ms/XGH8VL

Choose the DelayedUpdatingOfPathfindingSpeed.capx

I'm putting the Pathfinding behaviour through its paces! I have got it almost working using boolean variables to control the animations, but it's twitchy and would ultimately be unsuitable. The CAPX I've linked to doesn't have the boolean animation controls, it relies purely on the output of the Pathfinding behaviour.

Steps to reproduce:
1. Give sprite the pathfinding behaviour and define the conditions of changing animations (in this case speed)
2. Observe.

Observed result:
The sprite's speed variable doesn't update instantaneously when it has arrived at its destination. It does stop moving, but the speed variable seems to stick for a second or so before switching to zero.

Expected result:
Sprite should switch from the "running" animation to the "default" animation as soon as it arrives at its destination.

Browsers affected:
Chrome: Yes

Operating system & service pack:
Windows 7, latest Service Pack

Construct 2 version:
r119
slap it onto the flappy bird template...
bang it on google play with all the other shovelware...
sorted...
B
36
S
7
G
4
Posts: 322
Reputation: 8,170

Post » Fri Feb 15, 2013 5:33 pm

Should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528

Post » Fri Feb 15, 2013 6:56 pm

A gift for you @Ashley for being awesome:

slap it onto the flappy bird template...
bang it on google play with all the other shovelware...
sorted...
B
36
S
7
G
4
Posts: 322
Reputation: 8,170


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests