Delete sprite with 3 fames ingame

Get help using Construct 2

Post » Wed Jun 26, 2013 9:28 pm

So, i have a kinda like "3, 2, 1, GO!" Sprite wich has 4 frames. The 3, the 2, the 1 and the go. And im trying ingame to after the "go!" The sprite gets deleted. I tried with when frame=4 delete the sprite and couldn't get succesefill.. any help pls?

Tkx
B
7
S
1
Posts: 21
Reputation: 647

Post » Wed Jun 26, 2013 10:10 pm

The last frame would be 3, not 4. You can use On finished.

Add a blank frame at the end, and it should work as you want.
ImageImageImage
B
71
S
21
G
212
Posts: 3,615
Reputation: 119,649

Post » Wed Jun 26, 2013 10:18 pm

Thank you for the fast response.

But on finished asks me for the animation name while i'm using frames.

The other method worked just fine, but killing it wouldn't be more correct? It wouldn't consume system resources.
B
7
S
1
Posts: 21
Reputation: 647

Post » Wed Jun 26, 2013 10:54 pm

If you've just added frames and not changed the name of the default animation than the name you're asked for is "Default".

You can see it in the animations bar.

Since you are destroying the sprite object, what more are you asking for ?
Here is an example capx.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
279
S
104
G
86
Posts: 7,313
Reputation: 84,331

Post » Thu Jun 27, 2013 12:18 am

Thanks mate.. I was doing it correctly but i forgot on the layout properties to define the Event Sheet correctly (i have multiple layouts and multiple event sheets).

Thank you very much.
B
7
S
1
Posts: 21
Reputation: 647


Return to How do I....?

Who is online

Users browsing this forum: plinkie, Yahoo [Bot] and 2 guests