Dialog "Edit theme color" misses functionality

Bugs will be moved here once resolved.

Post » Sat Sep 07, 2013 12:54 pm

Link to .capx file (required!):
This is an user interface issue of C2 itself. I refer to this post instead: http://www.scirra.com/forum/topic68143_post451577.html#451577

Steps to reproduce:
1. Start Construct 2
2. Open the "Edit theme colors" dialog
3. Try to change any color

Observed result:
Colors can't be changed due to further actions (opening color picker) missing.

Expected result:
Being able to change a color.

Browsers affected:
Chrome: no
Firefox: no
Internet Explorer: no

Operating system & service pack:
Win XP SP3, 32-bit. Balloon tips disabled. Graphics drivers up-to-date. Tested as user and as administrator.

Construct 2 version:
r139 stable
Image
B
24
S
8
G
10
Posts: 1,821
Reputation: 8,279

Post » Tue Sep 10, 2013 1:14 pm

So you click a color in the list and nothing happens?

It works fine on Windows 8, and I checked the documentation for all the functions we use and they are all supported on XP as well. Have you got Internet Explorer installed and updated? Uninstalling it can disable some Windows features which could be the cause of this.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143

Post » Tue Sep 10, 2013 2:55 pm

[QUOTE=Ashley] So you click a color in the list and nothing happens?[/QUOTE] Right.

[QUOTE=Ashley] Have you got Internet Explorer installed and updated? Uninstalling it can disable some Windows features which could be the cause of this.[/QUOTE] Internet Explorer 8 exists and gets updated regularly through the system updates (mainly security issues). Its version number says 8.0.6001.18702 which I believe is the last published version.

Is the color picker that is not opening the same as the one from the image editor? That one works, so what is the difference?

What makes me wonder is that nobody else already mentioned this or is confirming. I hope I'm not the only one using XP SP3 32-bit with C2.tulamide2013-09-10 14:55:52
Image
B
24
S
8
G
10
Posts: 1,821
Reputation: 8,279

Post » Fri Sep 13, 2013 12:46 pm

It's the same popup, yes. I've done an attempted workaround for Windows XP in the next build. Let me know if that fixes it.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143

Post » Tue Sep 17, 2013 7:21 am

@Ashley
There's no change in r144.2
The color picker still doesn't show up.
Image
B
24
S
8
G
10
Posts: 1,821
Reputation: 8,279


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests