Dialogue system problems...

For questions about using Classic.

Post » Thu May 14, 2009 1:39 am

Hi guys!

I've been prototyping my game for some time now, and the last feature I want to implement is a fine dialogue system. I used Rich's very simple design to load my strings into a Hash Table as a start, but I could go a bit further because there seems to be a problem with the Timeline object :(

Rich's Dialogue method:
viewtopic.php?f=16&t=3407

So...
I was trying to use this method along with a timeline object to create a time progressing (unskippable for the moment) talking.

I wanted to use parameter 1 to indicate which character and expression - "npc1angry", for example - and parameter 2 to indicate the key at the hash table - the line NPC would say.

However, if I try to use:
Always --> DialogText: Set Text to HashTable(Timeline.Param(2))
...I get a "O" (zero) at output.

* I tried to use "str()" on different parts of the that line, but nothing happened.

On another test, I used:
On period "period1" begin --> Set Text to HashTable(Timeline.Param(2))
And I still got ZERO :(

Do you think this is some kind of bug? What could be wrong here?

BTW, using " HashTable("Line1") " returns the text perfectly, so this is probably something with the Timeline.

Thanks for the help!
B
107
S
40
G
10
Posts: 456
Reputation: 13,202

Post » Thu May 14, 2009 9:08 am

Could you upload the .cap file please?
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529

Post » Thu May 14, 2009 1:13 pm

Hey Rich, thanks for replying.
My website is currently down, so I had to use rapidshare for this 13kb file :(

The file has some of my tests that I previously talked about separated into Key presses :P

Edit** Hang on... I did some stupid stuff, I need to change the cap

Edit2**

Here... the file's updated:
http://www.willhostforfood.com/access.php?fileid=66272

I managed to get the dialogs running using "On Period Begin"... But this method is no good: Doing it like this, It would be better to type the whole sentences on the event sheet :P
B
107
S
40
G
10
Posts: 456
Reputation: 13,202


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 4 guests