Different game speed on different devices (despite of dt)

Just started using Construct 2? Post your questions here

Post » Tue Dec 01, 2015 1:25 pm

Hi all,
a question about time.

My game adds, every tick, dt in a variable and shows its value in a Text object on
screen (just for test purpose). Timescale = 1.
On both my PCs, one running the game at about 40 fps and the other one at 60+ fps, the value showed
is almost exactly the same of that on my wrist chronometer: I start game and chronometer at the
same time, and when the chrono reaches, say, 60 seconds, on screen appears more or less
the same value.

But on a phone Motorola Moto G (Android 5.0.2, running at 40 fps, timescale = 1) things are
different: when the chrono reaches 60, the value on screen is still at 55, and other 5 or 6
more seconds are needed to reach 60. And the game runs just a bit, but visibly, slower
(this is why I performed this test). Of course I do an extensive use of deltatime in my project,
but in this case it is useless.

Note: the PCs tests are performed in preview, the phone test via a build with Intel SDK (without Crosswalk).

Probably I misunderstood something - but what? and if not... is a workaround possible? just to make
my game running at the same speed on all devices.

thanks in advance (also for the effort to read my english ;) ) )
B
25
S
3
G
1
Posts: 31
Reputation: 1,488

Post » Wed Dec 02, 2015 6:56 am

I think you need to take a look at the manual on optimization and search the tutorials as well.
Image
B
75
S
23
G
3
Posts: 673
Reputation: 9,273

Post » Wed Dec 02, 2015 4:18 pm

already done, of course, and not only once :) ... but I don't struggle for a better fps value (40 fps on mobile are ok for my needs) but for a correct time computing on all devices...
B
25
S
3
G
1
Posts: 31
Reputation: 1,488


Return to Beginner's Questions

Who is online

Users browsing this forum: No registered users and 1 guest