Distort Map & 3d

For questions about using Classic.

Post » Sun Mar 03, 2013 5:54 pm

Hi! After watching a video about implementing a 3d engine in html, it looks quite simple son I make a try converting it to Contruct. I have got really quickly a moving camera between point in a 3d space. So I have decided to go further, and try to insert a texture between 4 points. I have used distort maps. The result is quite good, but the sprite distortion is very strange. I am not sure if it is a distort map "limitation" or I am doing something wrong applying it.

arrow keys to move and right-left mouse for raise and descend the camera

https://dl.dropbox.com/u/472186/Construct/Forums/demo3d.zip

Here the reference if anyone want see it:
https://vimeo.com/31129124
B
30
S
15
G
10
Posts: 285
Reputation: 7,144

Post » Sun Mar 03, 2013 7:37 pm

It looks like the uv's are changing. Unless you want a sub-texture, u and v displace should be left at 0.
B
79
S
24
G
54
Posts: 4,749
Reputation: 40,761

Post » Sun Mar 03, 2013 9:08 pm

Thanks, but I am changing only x and y positions. The UV displace and z position are always 0.
B
30
S
15
G
10
Posts: 285
Reputation: 7,144

Post » Sun Mar 03, 2013 9:59 pm

Edit: Read too fast... Standby while I test something out...

It will probably be fixed if you incorporate z position. With z position the texture will look correct with perspective. It also has the added benefit of eliminating the need to manually do the perspective transform. R0J0hound2013-03-03 22:22:51
B
79
S
24
G
54
Posts: 4,749
Reputation: 40,761

Post » Mon Mar 04, 2013 9:23 pm

Thanks, I will try chaging z values and see what I can get.
B
30
S
15
G
10
Posts: 285
Reputation: 7,144


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 0 guests