Does NO ONE else have this UI crashing problem?

For questions about using Classic.

Post » Sun May 16, 2010 1:15 pm

I've put up with this problem since I think the beginning. Occasionally Construct will just hand me an error message and screw up Construct when I try to open the expression editor in the event sheets. Now, I haven't been real angry at this until I switched from XP to Windows 7 where now I can't even click this error window away, save, and restart Construct to have it behave normally again.

So now I'm working with a ticking timebomb of frustration that will randomly have me lose progress. I really think it has to do with Construct evidently re-rendering all the sprite, etc. icons you can see in the expression window and event sheet window, because it always happens inbetween clearing those lists to redraw them again.

I specifically read someone saying they had no crashing issues with Construct in the latest version (0.99.84) so I switched to it, but no, the problem persists. Is there any way I can fix this, because I have no idea how I'll put up with it if I can't save...
B
5
S
2
G
3
Posts: 234
Reputation: 1,818

Post » Sun May 16, 2010 2:56 pm

That bug is a constant problem. You're correct, it's a memory leak that has to do with redrawing those icons and it particularly affects games with lots of objects in a layout. Basically, the more objects you have in a layout, the faster it'll crash. Obviously, working with an event sheet is even worse because that lists all of the objects for the entire game. I can open the expression editor maybe five times in an event sheet before construct crashes. The picture editor also contributes to the memory leak, and so does editing events in the event sheet without opening expression editor (though much less). I think it's been posted to the tracker three times. I mentioned it to one of the devs and they said that section of the code was a mess.

Regardless, I think this bug is the most important one that needs to be fixed. I've had to resort to finding ways to avoid opening the expression editor - I search for some other event that has a similar condition or action, copy and paste it and edit it, but that doesn't work if I have to change what variable it affects or such. Lately I've been trying to use a blank layout and paste the few objects I need into it and code there, then copy the code back into other event sheets, but deleting objects from a layout of a game the size of the one I'm working on takes a long time. Like seriously, I might as well go watch a TV show while it's doing it.

PLEASE scirra people, please fix this bug!! Even if that section of the code is a mess, is there some way that we could just not display those icons? I know most of the commands and don't use that section to retrieve them very much at all anymore, and if I need to, I can check it in another layout.
Moderator
B
88
S
32
G
33
Posts: 3,005
Reputation: 27,422

Post » Sun May 16, 2010 3:29 pm

Seriously, that icon window could at least be dropdown, and thus loads on the command to drop down. Of course I'd rather have it fixed properly.
B
5
S
2
G
3
Posts: 234
Reputation: 1,818

Post » Sun May 16, 2010 6:50 pm

This sounds familiar, but I haven't come across it much, thankfully.

I'm wondering how much Construct is being developed currently.
David has only posted about 28 times this year, and Rich has only posted twice!
Ashley still seems to be around, but I don't know what sort of priority Construct has with the Devs at the moment.

There's always a chance of this happening with indie programming.
I just hope that Construct hasn't "served it's purpose", and that they decide they no longer have time for developing it.

On the other hand it could just be the nice weather. :)

I hope they do sort this problem out if and when they get back to it.
I just hope it doesn't start happening to me in the meantime. ;)

Krush.
B
2
S
2
G
3
Posts: 406
Reputation: 2,062

Post » Mon May 17, 2010 2:55 pm

Yeah, the activity is a bit low nowadays. Rich is no longer active part of Scirra, I think. Ashley and David are busy in real life as well, but they're working on Construct (two bugs were closed in the last 10 days according to the tracker).

I believe the goal is to make Construct stable enough.
B
62
S
21
G
12
Posts: 1,910
Reputation: 13,155

Post » Mon May 17, 2010 4:08 pm

I've had this problem, but thankfully in my games it only happens after about a half-hour of work. It is EXTREMELY annoying; I have lost progress quite a few times. Now I make sure to save very often. Sometimes I forget to save however, and I curse when the ui goes all white and error-soundy on me.
B
25
S
3
G
6
Posts: 1,197
Reputation: 5,620

Post » Mon May 17, 2010 7:33 pm

This is pretty much the only thing that makes Construct crash for me. It usually only happens after a relatively long time, though. Since I save often, I don't usually lose much progress if at all.
B
16
S
8
G
4
Posts: 136
Reputation: 3,144


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 3 guests