Doesn't launch with Steam

Discussion and feedback on Construct 2

Post » Wed May 15, 2013 3:53 pm

It would probably help if you share your system specs, as that's the only way this is likely to get resolved. I find it unlikely that this is linked to Windows 8 - your friend's laptop likely has different specs, so I wouldn't recommend drawing conclusions from there.
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Wed May 15, 2013 4:06 pm

@chrisriis - does the standalone version from our site work? (You will only get the free edition though since the license from Steam works differently)
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Thu May 16, 2013 4:27 pm

@Ashley - The free standalone version works perfectly on all my PCs, so it should have something to do with the communication between Steam and Construct.

This is what happens: You launch Construct from Steam, and then a Steam-window flashes for 1 sec or something at the bottom of the screen (as if it's about to launch), but then nothing happens. If you click on Launch again/multiple times, it will tell you that the app is already launched.

I hope this helps :)
B
10
S
2
G
2
Posts: 27
Reputation: 1,920

Post » Thu May 16, 2013 5:22 pm

It's strange because AFAIK it works for 99% of people using it on Steam. The Steam version is also almost totally identical to the version from our site, apart from the small change that instead of loading a license file, it asks Steam whether the app is purchased. So my best guess is it's somehow a problem with Steam.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Thu May 16, 2013 8:24 pm

I'd try to see if you can launch the EXE from the steamapps/common/Construct2 folder. If you can launch that (it'll be in free mode) then it's definitely an issue with Steam initializing something. If it doesn't open, then it's an issue with the download from Steam.

If it's a problem with Steam initializing, uninstall C2 from Steam (all versions), then reinstall Steam. (Easiest thing to do is remove everything but Steam.exe and SteamApps folder. I recommend backing up all those files to a copied folder before doing so *excluding the SteamApps folder as it's all your games*)

If you still have problems after that contact Steam support.
B
15
S
4
G
4
Posts: 294
Reputation: 3,225

Post » Tue May 21, 2013 1:46 pm

@Thndr - I've tried these steps without any luck, but thanks anyway. I agree that it may have something to do with the Steam init.

UPDATE: It works if you allow beta updates in Steam. This is not an ideal solution, but at least a workaround for now.
B
10
S
2
G
2
Posts: 27
Reputation: 1,920

Post » Tue May 21, 2013 2:48 pm

@chrisriis - we should make a stable update soon, which should fix it for everyone regardless of using beta releases.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Wed May 22, 2013 5:59 pm

@Ashley - That sounds awesome! Keep up the good work ;)
B
10
S
2
G
2
Posts: 27
Reputation: 1,920

Post » Sun Aug 10, 2014 10:58 am

I hate steam. I had it installed but with month got rid of it. Waste of time
B
206
S
27
G
13
Posts: 1,841
Reputation: 35,812

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 1 guest