Drag and Drop behavior not working

For questions about using Classic.

Post » Fri Apr 29, 2011 1:40 pm

I'm attempting to use the drag-and-drop behavior to drag and drop objects in a game I'm making for my school library to teach students about the Dewey Decimal system. However, the object won't move when I mouse over it. I created a "Mouse and Keyboard" object, and the drag target can sense when it's being clicked on (I can make it flash), but it won't move. Is there something that I'm missing?

EDIT: I'm enabling/starting the behavior for the object when the layout starts.
B
1
G
1
Posts: 8
Reputation: 441

Post » Fri Apr 29, 2011 2:12 pm

Well I can't really tell what you did wrong, because I recreated your setup out of curiosity and it works like a charm. I added a ground and physics-behaviour just for fun.

Maybe you will spot a difference that could be the reason its not working for you:
http://dl.dropbox.com/u/12049513/Constr ... n_drop.cap

Best regards,
Noel
B
3
G
2
Posts: 35
Reputation: 770

Post » Fri Apr 29, 2011 2:34 pm

I figured it out. When I created the sprite, I made it out of two boxes and assumed that the interiors would also be part of the object. They weren't. Derp.
B
1
G
1
Posts: 8
Reputation: 441

Post » Fri Apr 29, 2011 3:25 pm

On the picture editor for sprites, there's a weird icon you can click that let's you change the collision mask, so you could have transparent spots still be clickable
Spriter Dev
B
87
S
21
G
12
Posts: 3,240
Reputation: 16,461

Post » Fri Apr 29, 2011 3:53 pm

It was a placeholder sprite anyways ;P
B
1
G
1
Posts: 8
Reputation: 441


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 11 guests