Edge (browser) audio looping lags

Bugs will be moved here once resolved.

Post » Wed Apr 27, 2016 12:44 pm

Problem Description
Audio looping on Edge is laggin'

Attach a Capx
https://dl.dropboxusercontent.com/u/714 ... ngBug.capx

Description of Capx
Reproduces the bug

Steps to Reproduce Bug
  • Compare the looping between Chrome and Edge

Observed Result
Looping lags on Edge

Expected Result
No lag on looping

Affected Browsers
  • Edge: YES

Operating System and Service Pack
W10

Construct 2 Version ID
227
Positive, inspiring and jazzy games!



www.crystalgames.space



Enjoy!
B
17
S
8
G
3
Posts: 173
Reputation: 3,453

Post » Wed Apr 27, 2016 5:27 pm

Closing as won't fix. I think this is to do with the encoding of the AAC file instead of a problem with Edge or Construct 2. Chrome and Firefox can play the Ogg Vorbis files which loop seamlessly, but Edge (and Safari) only support AAC. Due to the fact AAC is patent-encumbered we have to rely on the AAC encoder built in to Windows instead, and that sometimes pads sounds with silence which adds a gap to looped sounds. (I checked the files in Audacity and the .ogg is 4.571s and the .m4a is 4.621s, so it does look like the AAC was made unnecessarily longer.)

You can try to work around this by encoding the AAC with a different encoder and re-importing it. However there's not much we can do to fix it.
Scirra Founder
B
387
S
230
G
88
Posts: 24,251
Reputation: 192,464

Post » Wed Apr 27, 2016 7:56 pm

Thanks for your quick attention!

By the way, on Safari (both iOS and Mac) audio loops well, just as Chrome.
Positive, inspiring and jazzy games!



www.crystalgames.space



Enjoy!
B
17
S
8
G
3
Posts: 173
Reputation: 3,453


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests