Editbox broken?

For questions about using Classic.

Post » Sun Aug 30, 2009 8:16 pm

The Editbox works fine for me for user input. However, if the player leaves the layout and then returns.... the editbox is broken. The other layout is using the editbox and dialog panels as part of the "inheritance layer" option. However, this creates new Editbox and Ok buttons, etc.. I thought that the inheritance layer should just re-use the same objects?? So what happens is that when the player returns, the input is going to the new editbox, but the parsing of the box happens on the old editbox. Therefore, nothing works.

Has anybody else experienced this bug? Is there an alternative or workaround to this?


p.s. I just realized after I posted this that because I physically layed out the editbox ,each time I enter and exit the layout a new editbox will be created... I could solve this by dynamically creating the editbox at runtime, but then I can't use the inheritance layer feature. Any ideas?
B
8
S
3
G
7
Posts: 835
Reputation: 5,313

Post » Sun Aug 30, 2009 11:08 pm

I'm getting in a bad habit of responding to my own posts. :-) I decided to just dynamically add the editbox to any layouts that needed user input. That solved the problem.

I guess the inheritance layer is best used for background objects on the layout. I'll experiment some more with it.
B
8
S
3
G
7
Posts: 835
Reputation: 5,313


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 1 guest