Editing Layer Effects at Runtime

For questions about using Classic.

Post » Thu Sep 27, 2012 11:00 am

Is this possible yet? I found a thread about it from 2009 where the devs said it was being considered: http://www.scirra.com/forum/manipulating-layer-effects_topic36611.html

I'm trying to manipulate a warp layer effect for water in my game, so that the warp speed looks consistent whether you are standing still or moving in either direction. Using the canvas object leads to some very odd visual artifacts
B
15
S
7
G
7
Posts: 250
Reputation: 5,298

Post » Thu Sep 27, 2012 11:31 am

Yes, it is possible. You find the action under system/layer/set layer effect param

Just make sure you enter effect name and parameter name exactly as you see them in the layer effect properties
Image
B
23
S
8
G
10
Posts: 1,820
Reputation: 8,242

Post » Thu Sep 27, 2012 12:49 pm

Thank you!

I was ready to give up on the pretty warping water
B
15
S
7
G
7
Posts: 250
Reputation: 5,298

Post » Thu Sep 27, 2012 3:57 pm

Spoke too soon. I can't seem to make much sense of it.

The values I change the Y Speed of the Warp Effect to seem to ignore common sense, and have rules unto themselves. Check out this quick .CAP I put together to show the issue:

http://dl.dropbox.com/u/31971596/WTF.cap

The wave starts out with a Y Speed of 5.
Left Arrow sets it to -50
Right arrow to +50
Up Arrow to 100
Down Arrow to 1
A sets it to 60 (so you'd expect it to be slightly faster or slower than 50)
S sets it to 40 (again, slightly slower or faster than 50)
W should set the value to 5 again.

The results however... are bizarre. It's like each value has its own speed, completely irrelevant to the speeds of similar values. So while 50 is a moderate speed, 40 and 60 are batsh*t insane. And setting it to 5 using the W key is a completely different speed to the default 5.

Maybe I'm missing something? Either I'm using it wrong, or the action isn't working as intended.
B
15
S
7
G
7
Posts: 250
Reputation: 5,298

Post » Sat Sep 29, 2012 1:02 am

[QUOTE=-Silver-]Either I'm using it wrong, or the action isn't working as intended.[/QUOTE] Neither
I know the action works correctly, because I use it so many times. For example in the example game "Verve!", or in the day-night-cycle demo of the Color Fusion (Masked) effect. Both of them downloadable (is this a valid word?) somewhere on the forums.

But I remember that I also had a lot of problems when trying to animate parameters of the warp effect. It seems to be the effect itself. Normally, I'd advise you to contact the author. But in this case it's Ashley, and I'm pretty sure he won't have time to look after it.

I'll send you a pm.
Image
B
23
S
8
G
10
Posts: 1,820
Reputation: 8,242


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 3 guests