"ef_deprecated" (only) will return error

For developers using the Construct 2 Javascript SDK

Post » Thu Jul 17, 2014 3:51 am

Hi, plugin makers and @Ashley

In the latest C2, if the expression only has "ef_deprecated". It will rise an error when open C2.
It is better to be "ef_deprecated | ef_return_number" or "ef_return_number | ef_return_string".
B
108
S
26
G
272
Posts: 4,471
Reputation: 152,277

Post » Thu Jul 17, 2014 9:44 am

This is by design. Even deprecated expressions need to specify a return type, because they can still be in use in projects.
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,625

Post » Thu Jul 17, 2014 10:36 am

Thanks. Some 3rd plugins had this problem. Just a notification for us.
B
108
S
26
G
272
Posts: 4,471
Reputation: 152,277


Return to Javascript SDK

Who is online

Users browsing this forum: No registered users and 1 guest