Ejecta build fail help - please

Discussion and feedback on Construct 2

Post » Thu Oct 10, 2013 3:29 am

I didn't want to spam up the Ejecta thread with my personal problems... Can someone please help me with a build fail problem that repeats across a couple of projects? This Ejecta export option has me very excited - and very frustrated...

I've been trying to build a couple of projects using a virtual mac running xcode 4.5, using the latest developmental release of Ejecta, as per the tutorial. I've tried to carefully follow all of the guidance and, after MANY re-attempts at following the steps I'm now familiar and I think I've done everything right, but I keep on getting the same build failure in xcode. That was with one of my mobile projects, so I then tried a super-simple project with one touch object and still get the same failure. Here's a screenshot of the xcode failure notification:

https://dl.dropboxusercontent.com/u/184657779/xcode%20build%20fail.png

and for completeness, here's a capx of what I tried to run on the ios simulator:

https://dl.dropboxusercontent.com/u/184657779/ios%20test.capx

I must confess to being a complete newb with anything mac, so it's probably something simple...

Anyone any ideas what I'm missing?

Thanks!
I only occasionally visit - I'm learning C# for Unity, but c2 is still a respectable game engine imo....
B
73
S
19
G
66
Posts: 2,198
Reputation: 42,188

Post » Fri Oct 11, 2013 12:56 am

OK, if I build with xcode 5.0 and enable Game Center then the app builds (hoorah! - although it sticks on the login...). If I disable Game Center then the build fails with the following error codes:

https://dl.dropboxusercontent.com/u/184657779/xcode%20build%20fail.png

Anyone any ideas what I might need to do to rectify?

Thanks.
I only occasionally visit - I'm learning C# for Unity, but c2 is still a respectable game engine imo....
B
73
S
19
G
66
Posts: 2,198
Reputation: 42,188


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 4 guests