Ejecta Issues - Black Screen

Discussion and feedback on Construct 2

Post » Fri Dec 05, 2014 1:15 pm

KFC wrote:1. Change "Fullscreen in browser" in C2 to "Scale inner" (letterbox scale was probably the cause of the black screen)
2. In Xcode, on the General tab, Device orientation, uncheck portrait/upside down and check Landscape Left and Landscape Right, or on or the other.
3. On the info tab, find "Initial interface orientation" and select "Landscape (left home button)" or right home button.


@KFC I followed your directions in combination with Ashley's tutorial, and I still get a black screen. I'm not minifying my project, it's just not working.

Are you testing it on a simulator, or a device? May I ask how long the app took to load on yours? I sat and watched it this time, and after about 1 minute, the iPad retina simulator rotated 90 degrees and an iPad menu appeared (maps, etc). After about 30 seconds, all the icons apart from Safari vanished, and it rotated back to portrait. 2 minutes after that, XCode informed me that it had lost contact with the device.

I'm exporting it as Ejecta, not HTML5, and I'm downloading the Ejecta project from the link in the tutorial. Copying the export into that folder and replacing the name of the folder as "App". Once done, I'm double clicking the xcode project, setting the settings as you say, and then running the build (which says it's built successfully).

I've done a fresh OS upgrade, as well as a new xcode install. There must be a step somewhere that I'm missing.

I should say I have WebGL on, as I read that Ejecta supports it now.
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
84
S
15
G
7
Posts: 991
Reputation: 11,231

Post » Fri Dec 05, 2014 3:13 pm

I've tested it on the iPhone 4.
Now that I have tried a few simulators, iPad Retina and iPad 2 give me an error after the game launches, iPhone 5s, 6, 6 plus and iPad Air just fail to build altogether.
Although iPhone 4s and iPhone 5 simulators work correctly.

I'd suggest testing on a few real iDevices and see what happens.
B
33
S
12
G
7
Posts: 227
Reputation: 7,582

Post » Tue Dec 09, 2014 5:17 am

Not to hijack the thread, but I was experiencing the same problem until recently. At first it was just a black screen for any of the simulators followed by (eventually) an error message saying connection was lost, but by and by I managed to get it to the point where it displays the Ejecta logo. Unfortunately that seems to be as far as it will go before suddenly saying connection was lost. I tried hooking up an iPad and it displays the Ejecta logo with no end in sight. What might the problem be now?


Edit: Nix all that, it seems I got it working.
B
54
S
24
G
18
Posts: 295
Reputation: 13,140

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 8 guests