Ejecta sound error

Bugs will be moved here once resolved.

Post » Fri Sep 05, 2014 2:50 am

Problem Description
The game starts after exporting to Ejecta and compilation on xCode, but after loading of sounds application crash happens.
This does not apply to music.
If I remove all the sounds and left only the music, then the application starts up and works fine.
At Cocoon JS everything was fine.
Before the import all the sounds including music converted to Adobe Audition in wav / 44100/16 bit / mono, and then
C2 automatically converts everything to m4a as usual.

Attach a Capx
I can not attach capx.

Steps to Reproduce Bug

Observed Result
I have attached screenshots of the xCode bugs. The game does not start because of the sounds.

Operating System and Service Pack
Windows 7 x64 sp1

Construct 2 Version ID
C2 version r178 from August 19-th.
You do not have the required permissions to view the files attached to this post.
B
8
S
1
Posts: 26
Reputation: 502

Post » Fri Sep 05, 2014 3:03 am

One of the bugs suggests that some of the files in the wrong format, or not correctly coded.
I do not think this is the root cause as in the beginning of the game as I've added a new sound, which is converted correctly the converted, but still there is an application chush.
B
8
S
1
Posts: 26
Reputation: 502

Post » Fri Sep 05, 2014 5:32 am

Usually a problem of audio codec ( not compress or if you reduce you done ).
B
159
S
27
G
17
Posts: 917
Reputation: 32,677


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests